Jump to content
Sign in to follow this  
rhildebrand

Author Page Sidebar Problems

Recommended Posts

rhildebrand

Hi, I'm using PlatformPro and just noticed that it seems like my "Recent Posts" sidebar widget is causing the layout of my author pages to appear incorrectly. The sidebar is appearing below the main body content. See example here http://blog.rmhonline.com/author/sarah-harvey/ Seems like the width of the recent posts widget is dependent upon the length of my post titles. I have the current custom code set for my author pages: #content.narrowcolumn { margin: 30px; float:left; width: 600px; } The layout for my pages are 688px for the main content area and 272px for the right sidebar.

Share this post


Link to post
Share on other sites
cmunns

Something is overriding the layout editor here, but you can redefine your narrowcolumn to fix it. ` #content.narrowcolumn { width: 510px; } `

Share this post


Link to post
Share on other sites
rhildebrand

Adam, That works as far as bringing the sidebar back up beside the main body content rather than below it, however it doesn't solve the problem. Using this method I'd have to adjust my width depending on the length of my post titles. For some reason on my author pages long post titles aren't breaking to two lines. I want the columns to be the same width on the author pages as with the rest of the site. Any further help would be appreciated...

Share this post


Link to post
Share on other sites
Kate

Hey Ryan, It seems you still have the "narrowcolumn" width set to 688px. Please try this instead in your custom CSS:

#content.narrowcolumn {
	margin: 30px;
	float:left;
	width:500px !important;
	}

Share this post


Link to post
Share on other sites
rhildebrand

Kate, Thanks, but that does the same thing as before. (Note: I made the change that Adam suggested to 510, then changed it back to 688, because I don't believe adjusting the width addresses the real problem). If you look at the sidebar on any other page of my site you'll see the post title "Celebrating the Best of Both Signing Ceremony with Sentara" is wrapped to a second line. For some reason on the author pages it is not and I believe that's what's causing the issue. Any suggestions? Help please this is driving me nuts!

Share this post


Link to post
Share on other sites
cmunns

It appears to be fixed now, what was the issue after all?

Share this post


Link to post
Share on other sites
rhildebrand

Adam, It's not fixed yet. Right now I'm using the CSS you suggested, which does bring the sidebar up to the correct position beside the main body content. However, I believe the real issue is with the title lengths in my "Recent Posts" section. See how it looks on the author page vs. the rest of my site? For some reason only on the author pages it's not bumping long titles to a second line. Any suggestions?

Share this post


Link to post
Share on other sites
catrina

Is your "Recent Posts" section the "Home" page? I don't see issues with the post titles on your Home page...


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
rhildebrand

Catrina, Not sure I understand your question. The recent posts widget links to each of my posts.

Share this post


Link to post
Share on other sites
catrina

Ah, I assumed your "Recent Posts" section was the blog page where your most recent posts are displayed. The long links in your "Recent Posts" widget aren't being bumped down to a second line because the width of the sidebar is wide enough to fit the entire lines of long links. Do you want the width of the sidebar in the author pages to decrease so that the links can do that?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
Kate

Hey Ryan, For starters, the sidebar on the last page you've linked to has a width set to it with this line of code:

.one-sidebar-right #pagelines_content #sidebar1, .one-sidebar-right #buddypress-page #sidebar1{width:272px;}[/codoe]
	
	So, try adding a line that's more specific and would apply to the author page too, like:
	[code]#sidebar-wrap{width:272px;}

Share this post


Link to post
Share on other sites
rhildebrand

Kate, I believe that did the trick. However, just before your message I was getting ready to post that I now suddenly have a new problem... My custom css settings have not changed since Adams initial response of: #content.narrowcolumn { margin: 30px; float:left; width:500px; } However, now my author page looks like this now (before I added the #sidebar-wrap code). Starting to think my author pages have a mind of their own. Thanks for your help!

Share this post


Link to post
Share on other sites
rhildebrand

Kate, Disregard my last. Somehow, my layout settings had changed (though I had not messed with these since first setting up the site months ago), so it was a simple fix. Your previous suggestion did indeed fix it. It's not a perfect match with my other pages, but close enough that I'm not sure anyone other than myself would notice (if you pay attention you'll see the margins change as you navigate between author pages and other pages on my site). Thanks for your help - now I can put this author page mess behind me!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×