Jump to content
Sign in to follow this  
rwmacdonald

Bug in Continue Reading Link Text

Recommended Posts

rwmacdonald

Hi, I run a dual-language (en/fr) site with qTranslate, quite successfully, _except_ when I set the "Continue Reading Link Text" setting in "Blog and Posts" to '[:en]Continue Reading[:fr]Continuer'. This field resets to the default after I save any other changes in the main Pagelines Settings interface. However, it works fine until I make changes.

Share this post


Link to post
Share on other sites
cmunns

What about other options in the settings panel? Do those stay as you make changes to those?

Share this post


Link to post
Share on other sites
rwmacdonald

The other options appear to stay. The first time I noticed anything, I was looking at the French version of a category page on my site, and the "Continue Reading" links said "(English) Continue Reading".. (I almost thought there must have been some divine intervention) Since that happened, I've experimented by switching the language with qTranslate before going back to the field to put in the [:en] and [:fr] translations.. but it still gets overwritten.

Share this post


Link to post
Share on other sites
Simon

It is not a bug, most admin options are filtered to strip out malicious js/xss thats why there is a filter. `continue_reading_link_text` A simple function in platformbase should be all thats needed. `add_filter( 'continue_reading_link_text', 'my_readmore_link' );` ` function my_readmore_link( $text ) { $text = '[:en]Continue Reading[:fr]Continuer'; return $text; } `

Share this post


Link to post
Share on other sites
fredrikakerman

Hi, I have a simular problem. I have translated the po-file into swedish and created the mo-file from that. All the translations work well except for the "Continue Reading"-link, which still shows in english. If I am going to add the above mentioned function; In which file should that be added?

Share this post


Link to post
Share on other sites
Simon

It uses the test set in the control panel ( if set ) if its blank it uses the text from translation file. So you have two options, either clear '"Continue Reading" Link Text (When Using Excerpts)' setting so it uses your translated text, or simply put the translated string straight in there.

Share this post


Link to post
Share on other sites
fredrikakerman

Thanks! Now it works.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×