Jump to content
Sign in to follow this  
markn

404 page and IE

Recommended Posts

markn    0
markn

Internet Explorer is intercepting the custom 404 page that comes with the Whitehouse theme and is instead displaying the IE error page. I've added an 'ErrorDocument 404 /wp-content/themes/whitehouse/404.php' directive to the .htaccess file in the sites web root but that doesn't seem to be helping. How do I get the themed 404 page to display in all browsers?

Share this post


Link to post
Share on other sites
Andrew    201
Andrew

depends on file structure. In most situations I've seen; IE will display the correct page. more details would be needed about your htaccess and file structure to figure this one out...

Share this post


Link to post
Share on other sites
markn    0
markn

Here's my htaccess file: # Start with some permanent redirects RewriteEngine On Redirect 301 /piano_teachers.html http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers Redirect 301 /early_childhood_teachers.html http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers Redirect 301 /violin_teachers.html http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers Redirect 301 /voice_teachers.html http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers # Force IE to use our 404 page #ErrorDocument 404 /404.php ErrorDocument 200 /wp-content/themes/whitehouse/404.php #ErrorDocument 404 /index.php?error=404 # BEGIN WordPress <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule> # END WordPress By changing the ErrorDocument to 200 from 404 I was able to force the error page to properly display in IE. With the declaration set to 404, IE intercepts the 404.php and displays its less than useful MSN page.

Share this post


Link to post
Share on other sites
markn    0
markn

The path to the theme provided 404 page is wp-content/themes/whitehouse/404.php, so my htaccess file looks like this: # Start with some permanent redirects RewriteEngine On Redirect 301 /piano_teachers.html http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers Redirect 301 /early_childhood_teachers.html http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers Redirect 301 /violin_teachers.html http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers Redirect 301 /voice_teachers.html http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers'>http://manhattanareamusicteachers.org/teachers # Force IE to use our 404 page #ErrorDocument 404 /404.php ErrorDocument 200 /wp-content/themes/whitehouse/404.php #ErrorDocument 404 /index.php?error=404 # BEGIN WordPress <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule> # END WordPress I can get the 404 page to appear in IE by setting the ErrorDocument declaration to 200 instead of 404.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×