Jump to content
Sign in to follow this  
tixcomix

Tags appending -2 or something.

Recommended Posts

tixcomix

My client is using platform pro and we thought we would tag the posts so they would be findable via URL http://example.com/?tag=taga or http://example.com/tag/taga This worked fine in a test harness, but when my client went to test her tags some of them worked and some didn't. She checked her posts for typos in the wp-control panel and didn't see any, but she noticed that if you hover over the tag it's actuall shows as taga-2 and lo and behold if you give the url http://example.com/?tag=taga-2 it returns all the pages tagged with taga We are confused. Where did these -2's come from and why some tags and not others? She is running wp3.1.2. I couldn't find anything on this in wordpress so thought it might be an artifact of the theme. Anyone else ever seen this

Share this post


Link to post
Share on other sites
kastelic

This looks like the same type of behavior that happens with the assigning of permalinks. For example if you make a page titled "My Page" and its permalink is automatically assigned to

http://mysite.com/my-page
and then you change the title to "Our Page" and also change its permalink, and then you try to make a new page called "My Page", it will assign the permalink
http://mysite.com/my-page-2

because the original permalink is still in the database somewhere and it won't allow duplicate permalinks in the database. The only way to get the original tag name back without the '2' after it is to manually edit this instance in the database using phpMyAdmin.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×