Jump to content
Sign in to follow this  
Michael_J

Default Link to Image

Recommended Posts

Michael_J

By default, photos that I upload link to the post. How can I change the default to "link to image" instead? I believe this is probably a WP setting, but I've asked in the WP forum and got no response. Thanks in advance. (Using Platform Pro, but probably doesn't matter?)

Share this post


Link to post
Share on other sites
ricardo

Hi Joseph, Where do these photos appear? Home page? Can you post a link to that page(s) please? Ricardo

Share this post


Link to post
Share on other sites
Michael_J

Any photo that is inserted into any blog post. http://enthios.com (I have changed these all manually so that the links refer to the image, which allows lightbox to operate.) Here is the default for inserting an image: K0LVF.png Here is the result after having to insert the image first, then go back to the edit screen to change the settings: bb2rN.png

Share this post


Link to post
Share on other sites
ricardo

I think that it keeps the last setting so in theory if you start inserting images with links to the image, it will do that always as default. Ricardo

Share this post


Link to post
Share on other sites
Michael_J

That is not the case. I recall there is a little selection button hidden away in one of the settings pages, I just don't remember where to find it.

Share this post


Link to post
Share on other sites
Kate

Hi Joseph, What that's actually doing is linking to the attachment, which in theory, could be an image, a file, etc. This is actually the default way of handling it.

Share this post


Link to post
Share on other sites
Michael_J

Hi Kate, I have two different sites with WP/Pagelines installations. One of them defaults to the "File URL" (this automatically enlarges the picture if you have lightbox enabled): tBePL.png The other defaults to the Post URL. This just links to a separate page showing the photo. 5wkAP.png Clearly, somewhere in either the PageLines settings or the WP settings, there is a default 'switch.' I just can't find it. I would like to change the default so that it links to the File URL.

Share this post


Link to post
Share on other sites
cmunns

I thought that it just remembered what your last action was...that's what it does for me anywya.

Share this post


Link to post
Share on other sites
Michael_J

That's my question. It doesn't do that for me. So I guess I'm wondering why I have two different installations and each one has a different default?

Share this post


Link to post
Share on other sites
catrina

The "link to image" setting can be controlled in the image settings within the post editor. From experience, I just change the image link manually so that it goes to where I want it to.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
Michael_J

Thanks Catrina but I was actually looking for a way to not have to do it manually, because I post many images each day. I did find the answer. Just change it manually, then click "Save All Changes." That updates the defaults.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×