Jump to content
Sign in to follow this  
sarahwhite

Carousal - cross-browser issues

Recommended Posts

sarahwhite

The carousel is not working properly on my site. I am using Platform Pro with the NextGen gallery option. Any suggestions on how to fix this? There are carousels here: http://sarahwhitetherapy.com/wordpress/team/sarah http://sarahwhitetherapy.com/wordpress/team/carli In Chrome, if you keep clicking on the arrow to the right (say five times) the images disappear and don't loop properly (also sometimes in Chrome the photos open in their own window instead of the Nextgen popup window format). In Firefox and Safari, the arrow buttons work (scrolls along and loops) but the photos open in their own window, not in the slide show format. Thanks very much! Sarah

Share this post


Link to post
Share on other sites
Simon

Seems to work fine for me in FireFox, have you tried clearing your browser cache? Do you have a scriptblocker like noscript installed?

Share this post


Link to post
Share on other sites
sarahwhite

The first time I tried on Firefox (on a Mac) it worked, the second time it didn't work (meaning that the gallery photos opened in a new window). It works sometimes and not others. Are you suggesting those things to troubleshoot? I would like the carousel function to work without the need to ask people to clear their cache every time they return to a photo page. What's important is that any surfer will see it working properly every time. Does that make sense?

Share this post


Link to post
Share on other sites
kastelic

Seemed to work fine in everything but Safari for me on PC. Have you tried disabling plugins to see if there's a conflict?

Share this post


Link to post
Share on other sites
sarahwhite

The only plugin I have active is the NextGen Gallery plugin, which I need for the carousal. Are you suggesting I deactivate and reactivate it? The carousel is very finicky for. For example, sometimes in Chrome the loop works, but it opens the images in a new window. Maybe 1/3 to 1/2 the time I test there is an issue. Thanks again for any suggestions.

Share this post


Link to post
Share on other sites
kastelic

No, I just meant other plugins that could be conflicting with that one. I will mark this for further developer attention.

Share this post


Link to post
Share on other sites
sarahwhite

Thanks very much, Jimmy. Does that mean I'll be hearing from a developer on the sooner side regarding this?

Share this post


Link to post
Share on other sites
Simon

The first page worked for me ok, carli's page did not however, the pics loaded in a new tab. Nice pics all the same, had to look at all of them just to check.

Share this post


Link to post
Share on other sites
Simon

Actually, after that, reloading both pages and they now work fine. Do you have any caching or CDN in place?

Share this post


Link to post
Share on other sites
sarahwhite

Thanks for checking it out. I would like the carousel function to work without the need to ask people to clear their cache every time they return to a photo page. What's important is that any surfer will see it working properly every time. I've had this problem on multiple computers. Does anyone know how to contact Support? On the Contact page it says that they offer technical support through the support forum, but it doesn't seem that they are...? Thanks!

Share this post


Link to post
Share on other sites
ricardo

It looks to me that you have an excessive number of images that overlap each other and this might be a matter of items vs available space. Can you please tell us what you have set for these values in your Carousel Settings page? - Rotating Carousel Items - Displayed Carousel Items - Scrolled Carousel Items Ricardo

Share this post


Link to post
Share on other sites
sarahwhite

Hi Ricardo, Thanks for pointing that out. I hadn't had those values set, but do now have them set the this: - Rotating Carousel Items - 30 - Displayed Carousel Items - 9 - Scrolled Carousel Items - 6 The photos are still opening in a new page for me a high percentage of the time. Is there a limit to the Carousel space? What does this entail? Thanks!

Share this post


Link to post
Share on other sites
ricardo

I'm not getting that random new page on any of the photo sets and I'm not sure this is related to any of the other reported problems. But maybe it will be easier to fix that ramdom thing if the rest is working fine. Can you please change displayed to 6 and scrolled to 1? Ricardo

Share this post


Link to post
Share on other sites
sarahwhite

Ricardo, Thanks for the suggestion. That does seem to help, and I've done a quick test and the images are opening up in the correct pop-up window. However, it would be nice to scroll more than one at a time. Do you have any suggestions on this?

Share this post


Link to post
Share on other sites
ricardo

Wow! Something is really wrong with your carousel... it's stuttering! This shouldn't be connected but what size do you have set for the thumbs in the carousel? Keeping the 30 Rotating Carousel Items and the 6 as Displayed, increase slowly the number of Scrolled Items and see how it behaves. Ricardo

Share this post


Link to post
Share on other sites
sarahwhite

The Next Gen gallery has the thumbnails set to 100x75. Yeah it is really messed up - not to mention the issues I'm having in Internet Explorer through a PC, which I started a new thread on. I increased the scrolled items to 3 and it's opening in a new window again. So... can development or support help with these kind of bug fixes? Or do I have a setting wrong?

Share this post


Link to post
Share on other sites
ricardo

Sarah, try to add those values (100 and 75) to the Thumbs Width and Height in the Carousel Settings page and see if the stuttering stops. Ricardo

Share this post


Link to post
Share on other sites
sarahwhite

Ricardo, thanks for the suggestion, I did that. Images are still opening in their own window instead of in the popup Nextgen gallery window. I'm not currently having problems with stuttering. Are you still? I need to check it on another few computers before I can say that for sure.

Share this post


Link to post
Share on other sites
ricardo

I don't have windows problems but the carousel is still broken. Choose something else than Shutter for the display of the images and gallery please. Ricardo

Share this post


Link to post
Share on other sites
sarahwhite

How do I do that? I don't see where I've selected "shutter."

Share this post


Link to post
Share on other sites
ricardo

Sorry, thought you might have that choice in the NextGen side (I don't use it) but while checking my site to compare to my settings and normal carousel behavior, I found out my carousel is stuttering too! I will bring this to the devs attention. Ricardo

Share this post


Link to post
Share on other sites
sarahwhite

Thanks, when can I expect a response from the developers? And in what format will they respond? In all the browsers I test some images open in their own window as well.

Share this post


Link to post
Share on other sites
ricardo

I don't know. I haven't still had time to report this. Would like to get some more info to help them pinpoint the issue but today I'm having trouble finding time for debugging. I suppose they will answer in this thread. Ricardo

Share this post


Link to post
Share on other sites
sarahwhite

Ricardo, what exactly do you mean by stuttering? My main problem is that 1) when I click on an image it sometimes opens in a new window instead of as the regular next-gen overlay window 2) when I hit the forward arrow multiple times the entire loop gets lost. I've moved the carousel page here so that I can work on the site without the bugs as much as possible. http://sarahwhitetherapy.com/wordpress/team/test

Share this post


Link to post
Share on other sites
ricardo

Stuttering: when you click in the forward or backward arrow the scroll movement is not fluid. Ricardo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×