Jump to content
Sign in to follow this  
jetrojack

No Text on Blog Posts

Recommended Posts

jetrojack

Hello, I am trying to add a blog to my website, www.trojacklaw.com. In settings>reading, "Posts page" is set to "Blog." I made it using WH pro. I am having some issues: 1. I went to "posts" in WP and made my first post and publically published it. However, on the website, the the title shows up but there is no text. What up with that? 2. On the website, when I click on the title of the post, I get a 404 page. 3. I think something is haywire with my permalinks. The posts made in WP have a permalink that is differnet from the blog permalink, www.trojacklaw.com/blog. Suggestions? Thank you, Joe

Share this post


Link to post
Share on other sites
catrina

1) You need to check your Pages And Posts options to see if your excerpt content or full post content is disabled. Go to Settings > Pages And Posts and under the Full Post Content Placement section, select Show full content on all blog pages. 2 and 3) The post permalinks are leading to "trojacklaw.com". Did you make any changes to any of your settings?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
jetrojack

Thanks Catrina!! on 1), I don't see any "pages and posts" option under settings. I just updated WP, so maybe it's gone? I looked under all the other settings options and didn't find anything for "pages and posts." Not sure where to go from here. I'll keep looking and post back if I find something. 2) and 3), not that I know of. The only change I made was under settings>reading where I made the page titled "blog" the post page. I did not make any changes under settings>permalinks. Thank you so much for taking the time to answer my questions- it really means a lot to me! Thanks, Joe

Share this post


Link to post
Share on other sites
jetrojack

Catrina, got 1) taken care of. I was looking in WP settings, but I found the "pages and posts" in the WH pro settings. Thanks so much!!! Issues 2) and 3) still remain. I will keep working on it, but any advice would be very much appreciated.

Share this post


Link to post
Share on other sites
jetrojack

custom structure: /trojacklaw.com. Nothing is in the blanks under "optional."

Share this post


Link to post
Share on other sites
catrina

You'll need to remove the "/trojacklaw.com" from custom structure or else the post links will keep on going to that link.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
jetrojack

Settings>general does not have any options for permalinks. Settings>permalinks are described above. I don't see a "general" tab in WP or WH pro. Am I missing something?

Share this post


Link to post
Share on other sites
jetrojack

haha, posted without looking first. I tried that, but if I completely remove that all the subpages (blog, values, etc.) go 404.

Share this post


Link to post
Share on other sites
kastelic

In Settings->reading check custom and then put this in there:

/%postname%/

Share this post


Link to post
Share on other sites
jetrojack

Great!! Thanks Jimmy!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×