Jump to content
Sign in to follow this  
roadsider

Platform breaks CSSEdit?!

Recommended Posts

roadsider

I use CSSEdit for my web development, and when I was trying to customize the PlatformPro Base template, CSSEdit suddenly started acting as if it were broken. This issue was driving me mad, until I opened another site I developed with CSSEdit and it worked perfectly. I don't know what, but there seems to be something in the Platform code that is breaking the program. When I launch it, I cannot select windows, I cannot save files, I cannot manipulate palates. It's a mess. Can you offer me any direction here? Thanks.

Share this post


Link to post
Share on other sites
kastelic

Sorry, can't really offer you direction here. There's no way a theme can break a code editor. There must be something else going on here.

Share this post


Link to post
Share on other sites
roadsider

That's what I had always thought, but I have never seen CSSEdit behave this way, and it only happens on this template. What else am I to deduce? The investigation continues...

Share this post


Link to post
Share on other sites
Kate

Hi Randy, Unfortunately I don't have any input on what could be the cause, other than to say I have heard of others using it successfully with Pagelines themes. Hope you get it figured out!

Share this post


Link to post
Share on other sites
roadsider

I finally had some time to go back to this issue. It turns out that Platform is definitely causing an issue here, and it's not really with the code editor part of CSSEdit, but the web browser that comes with it. When I open my style sheet for my project, CSSEdit is fine until I preview the pages in its browser. That's when the fun begins. In console, I'm getting an array of error messages. To wit:

6/30/11 9:13:51 PM CSSEdit[18292] *** Assertion failure in -[MRDualTextCell _objectValue:forString:errorDescription:], /SourceCache/AppKit/AppKit-949.54/AppKit.subproj/NSCell.m:1338 
and a steady stream of...
6/30/11 9:13:03 PM CSSEdit[18292] *** -[NSCFArray insertObject:atIndex:]: attempt to insert nil 

By this point, CSSEdit becomes unusable and eventually crashes. I want to emphasize here that this ONLY happens when I am trying to edit a Platform theme. The website can be found at http://www.roadage.com/clients/dreamdiner/ Any ideas?

Share this post


Link to post
Share on other sites
Simon

Try switching to inline css, dunno just guessing here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×