Jump to content
Sign in to follow this  
ronaldmeaux

400 - Bad Request Share on Twitter

Recommended Posts

ronaldmeaux

I uploaded my PlatformPro settings to a new site and now see this error message at the bottom of all my posts in the "Please consider sharing" section: 400 - Bad Request "title="Share on Twitter" rel="nofollow" target="_blank"> Any ideas on how to fix this? The website is http://remedypoint.com

Share this post


Link to post
Share on other sites
catrina

Based on searching around, this error is Twitter API-related. How did you upload Platform to your new site?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
ronaldmeaux

I used import/export.

Share this post


Link to post
Share on other sites
ronaldmeaux

To be more specific, I had already installed the theme on multi-site and network activated it. Later I exported the theme settings from one site and imported them into another.

Share this post


Link to post
Share on other sites
cmunns

And it worked in all cases normally before you exported, even on the multi-site? What theme version do you have...this is the current line of code that is relevant as of 1.3.5 `

Share this post


Link to post
Share on other sites
ronaldmeaux

Hi Adam - Yes, everything was working great on my multi-site before I did the import/export. And everything else seems to be working fine so far. I can't seem to find what version of the theme I'm using. What do you mean by "this is the current line of code that is relevant as of 1.3.5"? Am I supposed to do something with that code?

Share this post


Link to post
Share on other sites
timlinson

To check your theme version, go to Appearance > Themes, and the version will be next to the theme name. Regarding the sharebar code that Adam posted, that's what injects the twitter code, but on your page it's putting a strange html block. If you have 1.3.5, find that line in that file (line 53 in my version, about halfway down) and see if anything strange happened to it: wp-content/themes/platformpro/sections/wp/section.sharebar.php If you can't find it, go ahead and paste the whole file into something like http://pastie.org/ and link it here.

Share this post


Link to post
Share on other sites
ronaldmeaux

I'm using version 1.3.1. Here the link to the code in that file. http://pastie.org/1837247 I appreciate your help Tim, you're a good communicator. Where are you based? Let me know the next time you're in SF so I can buy you a drink.

Share this post


Link to post
Share on other sites
timlinson

That's odd, did you make any changes? I don't see the weird sharebar markup anymore.. izZ7I.png

Share this post


Link to post
Share on other sites
ronaldmeaux

No, it's still broken. I just turned off the Twitter share button because of the error. I did find the code Adam posted and mine looks just like his.

Share this post


Link to post
Share on other sites
cmunns

Okay I'll create a bug ticket for this then.

Share this post


Link to post
Share on other sites
ronaldmeaux

Adam, I'm not sure what that means. What are my next steps? Thanks, Ron

Share this post


Link to post
Share on other sites
ronaldmeaux

Thanks again Tim. Do I need to do anything or will Adam get back to me with next steps?

Share this post


Link to post
Share on other sites
ronaldmeaux

Adam, any updates on the bug ticket you created last week?

Share this post


Link to post
Share on other sites
Simon

This 'bug' is caused buy too many requests to the tinyurl service. I have patched a caching routine into 1.4.0 Email me at simon@pagelines.com and i will send you the patch directly.

Share this post


Link to post
Share on other sites
ronaldmeaux

Simon, My email is rtm@remedypoint.com. Please let me know what I'm supposed to do with this patch. Thanks, Ron

Share this post


Link to post
Share on other sites
timlinson

Hi Ron, actually 1.4.0 is officially out now.. should be able to pick it up in your launchpad page.

Share this post


Link to post
Share on other sites
ronaldmeauxmecom

1.4 did the trick. Thanks again Tim.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×