Jump to content
Sign in to follow this  
brempfer

wmode works but knocks out movie controls

Recommended Posts

brempfer

I loved finding the solution to the menus disappearing behind the movie/feature area. Very cool. Unfortunately when I set this up, the movie controls stop working in everything but firefox and in ie8 there is an artifact that appears over the top of the controls mystified utterly, I have played with z-index, different movie formats, and the different solutions to making the dropdown menus work, all to no avail. Somebody smarter than me please

Share this post


Link to post
Share on other sites
kastelic

Works in chrome, what browser does it not work in?

Share this post


Link to post
Share on other sites
brempfer

Thanks so much for answering back. Here's the crazy - In the following code if I use wmode "opaque" The movie runs in everything. Woo Hoo. Unfortunately in Chrome and IE it puts the menus behind the movie. If I put wmode "transparent" the menus are in front in all browsers, but it wipes out the ability of all to play the movie except Firefox (which friggin rocks among all browsers) <div id="lift"> <OBJECT CLASSID="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B" width="656" height="395" CODEBASE="http://www.apple.com/qtactivex/qtplugin.cab"> <PARAM name="SRC" VALUE="http://www.blackcanyonconsulting.com/wp-content/uploads/2010/09/bccg-northstar2.mov'>http://www.blackcanyonconsulting.com/wp-content/uploads/2010/09/bccg-northstar2.mov"> <PARAM name="AUTOPLAY" VALUE="false"> <PARAM name="CONTROLLER" VALUE="true"> <param name='wmode' value="opaque"> <EMBED SRC="http://www.blackcanyonconsulting.com/wp-content/uploads/2010/09/bccg-northstar2.mov'>http://www.blackcanyonconsulting.com/wp-content/uploads/2010/09/bccg-northstar2.mov" width="656" height="395" AUTOPLAY="false" CONTROLLER="true" PLUGINSPAGE="http://www.apple.com/quicktime/download/" wmode="opaque"> </embed> </object> </div> I have modded the css as requested in the forum to #header .content { position: relative; zoom: 1; z-index: 100; } #nav { position:relative; z-index:5000; /* ie drop-down fix */ } But that creates no love in IE ?? Lost here

Share this post


Link to post
Share on other sites
brempfer

Thanks Catrina Same situation. Leaving the wmode set to opaque, all of the movie controls work but ie8 and chrome the menus disappear behind the movie Setting wmode to transparent, all of the menus work, but the movie controls don't work in Safari, chrome, ie8. Thanks for taking a swing at it, but the problem remains.

Share this post


Link to post
Share on other sites
catrina

It might be possible that the menus aren't showing because of the Quicktime movie format. Have you tried adding a slide with a YouTube video (it could be any) just to test and see if the menus are still showing in the back?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
brempfer

Thanks Much Catrina This is obviously a problem. I need to go figure out better embed code for a different codec to meet the client's desire to host his own video rather than use one hosted on youtube

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×