Jump to content
Sign in to follow this  
dherries

Feature Transition Stop

Recommended Posts

dherries

I have a Feature Set with 9 features. I want it to stop transitioning at the end of the 9th feature. How can I do this?

Share this post


Link to post
Share on other sites
cshoffmann

The feature slider is controlled by jQuery cycle. So, to program it to stop after the 9 feature you need to edit the jQuery: autostop: 0, // true to end slideshow after X transitions (where X == slide count) autostopCount: 0, // number of transitions (optionally used with autostop to define X) end: null, // callback invoked when the slideshow terminates (use with autostop or nowrap options): function(options) Here is the jQuery Cycle Options page: http://jquery.malsup.com/cycle/options.html Now, the above says it is possible, but that does not show how to do it--so BEWARE before trying to do it. Platform Pro>Settings>Feature Settings does not have an option to stop the slides from "looping". So, we should request it in ideas and feedback and also find a way to accomplish it. I have not done it before, but will investigate it some time soon.

Share this post


Link to post
Share on other sites
dherries

I am clueless as to what I am doing here. I have inserted autostop:9,// into the jquery.cycle.js file (not sure where to insert it). The now the site only brings up the first slide and stops. http://productivitymastery.com/ Any thoughts?

Share this post


Link to post
Share on other sites
cmunns

The autostop:9 has to be added not in the js file itself but where the js is called e.g. the section.features.php file where you see this line: ` printf( "$j('#cycle').cycle({fx: '%s', sync: %d, timeout: %d, speed: %d, cleartype: true, cleartypeNoBg: true, pager: 'div#featurenav'});", $feffect, $fsync, $timeout, $speed ); `

Share this post


Link to post
Share on other sites
dherries

Do I insert it in the line, before or after the line? Sorry to be such a pain.

Share this post


Link to post
Share on other sites
dherries

I know that I sound inept at this but it is past my ability. I have entered these items where you suggested and it does not have any affect. I tried entering autostop: 9, // with no effect and then autostop:9,// autostopCount: 9, // end: null, // with not effect. What am I doing wrong? http://productivitymastery.com/

Share this post


Link to post
Share on other sites
cshoffmann

Here is where and how to put it: http://screencast.com/t/bxdlVbdIoZ <?php //Feature Cycle Setup printf( "$j('#cycle').cycle({fx: '%s', sync: %d, timeout: %d, autostop: 9, speed: %d, cleartype: true, cleartypeNoBg: true, pager: 'div#featurenav'});", $feffect, $fsync, $timeout, $speed ); NOTE: each time you upgrade Platform Pro you will have to edit this again.

Share this post


Link to post
Share on other sites
timlinson

you'll want it inside the cycle({ ... }) part, separated by a comma: `printf( "$j('#cycle').cycle({fx: '%s', sync: %d, timeout: %d, speed: %d, cleartype: true, cleartypeNoBg: true, pager: 'div#featurenav'`, autostop: 9`});", $feffect, $fsync, $timeout, $speed );`

Share this post


Link to post
Share on other sites
cshoffmann

@Tim, sorry I was editing my post right as you must have posted the solution as well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×