Jump to content
Sign in to follow this  
phxreguy

Dropdown menus resized - too large

Recommended Posts

phxreguy

Recently upgraded to WP 3.1.1 and PlatformPro 1.3.5 My dropdown menus at http://phoenixrealestateguy.com are functional, but the "boxes" in the dropdown menu are very wide. They used to be sized to fit the text (or were at least significantly less wide). I can't seem to use Firebug to examine and make CSS changes because if I hover over the dropdown to activate it, when I move my mouse off to go into Firebug, the dropdown goes away. In addition to looking ugly, if you hover over the "About" menu (under the header graphic)then go to down to "Legal" the sub-dropdown appears, but because the menu box is so wide, it pushes the right arrow for that submenu off the screen. Any suggestions?

Share this post


Link to post
Share on other sites
phxreguy

Also, if you navigate to a different page (or refresh the page) the dropdown menus flash briefly. They didn't use to do that...

Share this post


Link to post
Share on other sites
ricardo

Jay, Seems you haven't updated the platformbase theme. Have you tried to update (at least) the files you haven't changed? That would narrow down your problem. Ricardo

Share this post


Link to post
Share on other sites
phxreguy

Ricardo - Well there is a glaring omission. So I just upgraded Platform base (to 1.3.2) and the secondary nav menu (below the header graphic disappeared. Completely. I went into settings --> Header & Nav and selected the menu under "Posts Page Secondary Navigation". Still no secondary nav bar. Then I went into a couple of pages and tried setting is in the Pagelines Meta Settings. Still no secondary nav bar. What am I missing?

Share this post


Link to post
Share on other sites
phxreguy

OK, so I found where I had to add the secondary nav section into the header area. That brought back the desired nav menu, but now the dropdowns are gone from that.... *sigh*

Share this post


Link to post
Share on other sites
ricardo

Jay, Check your "Drop Down Navigation" options in Pageline Settings > Header and Nav. Ricardo

Share this post


Link to post
Share on other sites
phxreguy

Dropdowns are enabled in Settings --> Header & Nav. Other related issues - I can't get any sub nav to show on individual posts, no matter what is in the settings. I added a dropdown to the top nav bar (above the header graphic) for testing. It works, but still has the very wide box that was my original problem. Could this be a plugin conflict? That's all I'm left with as I'm stumped. But I'm just a real estate guy, clearly no designer/coder. Thanks for the help Ricardo! (and anyone else that happens to chime in)

Share this post


Link to post
Share on other sites
catrina

You can try deactivating your plugins to see if it is a plugin conflict and then re-activate each one at a time to find the plugin that's causing the problem.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
phxreguy

I deactivated all plugins, and am still having problems with drop downs and the secondary nav bar on posts. To recap: Running WP 3.1.1, PlatformPro 1.3.5 and Platform Base latest (1.3.2 I think) (all recently upgraded, and that's when problem started) Problems: 1)no dropdowns are showing on the secondary nav (below the header graphic). 2) The dropdown on the primary nav (above the header graphic) is VERY wide. 3) Nothing is showing in the secondary nav space on individual posts. What I've done: Disabled all plugins - no affect. Reinstalled WP, Platform Pro and Base - no affect. In settings for Header & Nav, dropdowns ARE enabled, and a menu has been selected for Posts Page Secondary Navigation. Any thoughts? This is driving me insane and the blog loses a lot of functionality without the secondary nav menu and the wide dropdowns. Any help would be greatly appreciated!

Share this post


Link to post
Share on other sites
ricardo

Jay, Looking at your code I realize that your menus are exactly as wide as the page, which leads me to believe that due to some sort of confusion "backstage", the menu width is being picked up from somewhere else, in this case from the page width's value. Here's a few things you can try, if you haven't already: - Change to another theme and then revert; - Change the theme's width (global content); - Change the theme's width and site design mode (fixed-width, full-width, full-width with canvas); - Revert options to default; Don't forget to export your settings before doing this! Ricardo

Share this post


Link to post
Share on other sites
phxreguy

Ricardo - Thanks for the tips! I tried them all, and found when I reverted to original settings, the dropdowns narrowed as they should. Reinstalling my setting made them go wide again. (but even at reverted settings there were no dropdowns in the sub nav below the header) I found some custom CSS that was throwing the dropdowns wide. So that is now fixed. I can live without dropdowns on the sub nav menu, but I'm still not getting sub navs at all on individual posts. That's problematic. I'm going to mark this topic resolved and open one just for that. Thanks Ricardo and Catrina for the help!!

Share this post


Link to post
Share on other sites
ricardo

You're welcome! =) Lets see if we can fix the rest as well... Ricardo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×