Jump to content
Sign in to follow this  
Gavin_

header custom code challenge

Recommended Posts

Gavin_

Hi - your help appreciated... I'm a bit confused. here is my site http://79.170.44.78/atabdemo.org.uk/ and it has all the latest versions of wordpress and pagelines. its a back up of my mine site http://www.atab.org.uk/ however, on the backup site i can't get the header to work as a custom background. #header { background-image: url ("http://79.170.44.78/atabdemo.org.uk/wp-content/uploads/2011/04/header.jpg") background-repeat:repeat-x transparent!important; } this code works great on another site so i am real confused as to what is causing the problem. am i better off just rebuilding the site from scratch? thanks

Share this post


Link to post
Share on other sites
cmunns

You are not using the same design style for both sites. One has the page-canvas...one is full-width

Share this post


Link to post
Share on other sites
Gavin_

the original and live site is built on an old version of pagelines that doesn't give you the page choice. the demo version http://79.170.44.78/atabdemo.org.uk/ does have the option - i have tried all three options but none seem to work! all help more than welcome.

Share this post


Link to post
Share on other sites
cmunns

I don't get why it's left aligned. There is something in your CSS that's got to be causing that bc none of the design styles would do this.

Share this post


Link to post
Share on other sites
Gavin_

ok - this is driving me nuts. i have now created a blank new site and still can't get the background image to tile behind the header... can someone please help? Adam, Catrina, Kate???

Share this post


Link to post
Share on other sites
Gavin_

i'm using exactly the same code on two different sites and on one it works and on the other it doesn't...

Share this post


Link to post
Share on other sites
Gavin_

ok - i've worked on a cheat as a temporary fix where i am using a blue colour for the header background. but really i don't understand why the custom code for the color worked but the image [email protected]? but now there is a white line at the top of the page and i can't locate it in firebug. i think it is the beginning of the page canvas - i would like the header to be at the top of the page and not this white space. so now i have two requests of you good people of pagelines. how do i a) get a tiled background image for the header branding b_ get rid of the white space above the header thanks...

Share this post


Link to post
Share on other sites
cshoffmann

@Gavin You currently have the custom css as: #branding { background-color: #00569A; height: 125px; background: url ("http://79.170.44.78/atabdemo.org.uk/wp-content/uploads/2011/04/header.jpg'>http://79.170.44.78/atabdemo.org.uk/wp-content/uploads/2011/04/header.jpg") repeat-x transparent!important; } Change it to: #branding { height: 125px; background: #00569A url(http://79.170.44.78/atabdemo.org.uk/wp-content/uploads/2011/04/header.jpg'>http://79.170.44.78/atabdemo.org.uk/wp-content/uploads/2011/04/header.jpg) repeat-x; } That will fix your CSS error. Here's a screenshot of the result: http://www.screencast.com/users/cshoffmann/folders/Jing/media/87d92edf-df7e-46a8-9f50-cd9ed493cd69 The white line at the top is from the Pagelines Full-Width design control setting. To eliminate you may add this code to custom css: body, body.fixed_width { background-color: #00569A; } or change the Body color in Design Control to #00569A

Share this post


Link to post
Share on other sites
Gavin_

@Shaun that is pure genius - thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×