Jump to content
Sign in to follow this  
zufalo_j7

PlatformPro 1.3.5 and Platformbase install broken

Recommended Posts

zufalo_j7

Hello, can anyone please help me get this install issue resolved? I would be very grateful. I tried three times today to install PlatformPro 1.3.5 and Platformbase. The last time, I even downloaded the latest versions of both from PageLines website, but it still isn't working and completely breaking everything. This is a new domain name install on a Media Temple Grid Service server. I'm using the 3.1.0 version of WordPress. I have done several successful installs of PlatformPro and Platformbase on this server. However, the ones that are working were done on the 3.0.1 and 3.0.4 versions of WordPress. Could this be the problem? Are PlatformPro 1.3.5 and Platformbase not compatible with WordPress 3.1.0? There are no plug ins even installed yet. I am uploading the ZIP folders exactly as recommended and as I have done successfully before. Both PlatformPro and Platformbase install fine, but everytime I try to activate Platformbase I get this error message: "Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /nfs/c07/h02/mnt/113227/domains/johnrwebster.com/html/wp-content/themes/platformpro/sections/nav/section.nav.php on line 13 Once this happens, I am locked out of being able to do anything. After deleting the WordPress install and re-installing it three times with the same results each time, I am reaching out in desperation for help. Please let me know as soon as possible what you recommend I do? I have a deadline that I need to meet. Thanks

Share this post


Link to post
Share on other sites
cshoffmann

I have escalated the topic for Developer Attention. Stand by.

Share this post


Link to post
Share on other sites
timlinson

This is usually a php4 error. PlatformPro requires php5, so you'll have to get in touch with your host about how to switch to php5.

Share this post


Link to post
Share on other sites
zufalo_j7

Thanks Shaun and Tim for your replies. I'll check with my host tomorrow about php5. But as I said, I have several installs of PlatformPro and Platformbase all ready working on this server, so I don't think that's the problem.

Share this post


Link to post
Share on other sites
Simon

PlatformPro requires PHP5. The error you are getting is the result of PHP4 being enabled on your host. There may be several ways to make the switch. Either through their control panel, via support or even `.htaccess` file. See http://www.pagelines.com/forum/topic/7390

Share this post


Link to post
Share on other sites
lujandesign

I had the same issue. Switched from PHP 4.4.9 to 5.2.13 and voil??! It works perfect. Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×