Jump to content
Sign in to follow this  
mickeboy89

How to link from the three feature boxes (WHP)

Recommended Posts

mickeboy89

I would like to link from the three feature boxes (fbox1 etc). There's nowhere to set a link in the settings, as far as I can make out, but I'm sure there must be a way of doing this... Can you help?

Share this post


Link to post
Share on other sites
Kate

Hey Mick, You could add the link in the HTML area and adjust its height/width with CSS.

Share this post


Link to post
Share on other sites
mickeboy89

Hi Kate, I added a link into the Feature Box Text + HTML area fro Feature box 1, as follows: Fbox1 code It works - but unfortunately it makes all other copy on the homepage into a hypertext link. Can you advise? Thanks (I'm going to have to revert to the original HTML now just so I can share the site with others involved in development). Mick

Share this post


Link to post
Share on other sites
Kate

Did you include a closing a tag? If so, what was the CSS (if any) that you added?

Share this post


Link to post
Share on other sites
mickeboy89

Hello Kate, I am a total novice with HTML and know zero CSS so thanks for trying to help me. I've tried adding HTML opening and closing but it didn't make any difference. I've made no changes to CSS, I wouldn't know where to start. The code currently looks like this: OmywZ.png I don't know if this helps you identify the issue? Thanks Mick

Share this post


Link to post
Share on other sites
cmunns

Hey Mick, You are missing a `>` after the end quote for a href="..."

Share this post


Link to post
Share on other sites
mickeboy89

Hi there, and thanks. It works for fbox1 (it makes the graphic a link, which is exactly what I wanted) - but unfortunately it makes the text and graphics in fbox2 and fbox3 into hypertext linking to that same page. I want to treat these two boxes differently with their own graphics linking on to different pages. Can you advise? Thanks Mick

Share this post


Link to post
Share on other sites
mickeboy89

I updated fbox2 following the same protocol (but using a different href link) - but unfort this does not change anything. It is as if fbox1 controls the other two boxes.

Share this post


Link to post
Share on other sites
Kate

Hi Mick, When you say it doesn't change anything, do you mean no link appears?

Share this post


Link to post
Share on other sites
mickeboy89

Hi Kate, sorry I didn't make that clear. 1. I got fbox1 working fine (the graphic links to the page I want). 2. Unfortunately is also makes every element in boxes two and three into hypertext, linking to the place I specified in fbox1. 3. Changing the fbox2 code to include a different link, (following the same rules I used in fbox1) does not solve anything. The copy remains hyperlinked to the link specified in fbox1. I hope that is clearer? And many thanks for sticking with me. It's very frustrating, as linking off these boxes is pretty fundamental, I wish I could crack it! Mick

Share this post


Link to post
Share on other sites
cmunns

You are also missing a closing `` tag just before the closing paragraph tag ``

Share this post


Link to post
Share on other sites
mickeboy89

cmunns and Kate, I am delighted to tell you I fixed the problem with your help and advice - thanks so much !!! http://debbonaire.co.uk/ Mick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×