Jump to content
Sign in to follow this  
mickeboy89

How to stop a Page automatically appearing in navigation (WHP)

Recommended Posts

mickeboy89

Trying to work out how to stop a new page from automatically appearing in the top navigation... can anyone help, please? Mick

Share this post


Link to post
Share on other sites
catrina

If you don't want pages to appear in the navigation, you can hide it temporarily using CSS:

li.page_item {display: none;}
This gets rid of all page links, but if you want to hide individual pages, you can use this CSS:
li.page_item page-item-# {display: none;}

Replace the # value with the page item number for that page.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
mickeboy89

Hi Catrina, I used the second bit of code and replaced the # with the page ID (246 I think) but the page ('Test') is still there... Mick

Share this post


Link to post
Share on other sites
Kate

Hey Mick, The other option is to use custom menus with WP. You can set it up under "Appearance->Menus". That way you can choose which items appear and which don't.

Share this post


Link to post
Share on other sites
mickeboy89

Hi Kate, that is very valuable advice - thanks, works a treat. Mick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×