Jump to content
Sign in to follow this  
vpsean

1 Post blog an straight to Comments + Delete 'page lines'

Recommended Posts

vpsean

Hey guys, I just got the PageLines WhiteHouse theme installed at www.SeanPatrickSimpson.com <-- Brand new site. Is there a way I can set the theme to be 1 page posts (ie. only displaying one post on the main page), so that people see the Facebook comments plugin right away? Here's an example of what I mean: * www.simpleology.com/blog * Notice how the blog only has one post, and directly beneath it you see the comments? That's what I'd like. Can someone tell me how to accomplish this? Also, after purchasing these themes, is it required to keep the PageLines branding on it? For my sites purposes I'd prefer no external branding. At the bottom of the 1st post you see on the site right now, it says "PageLines". Thanks a ton guys!

Share this post


Link to post
Share on other sites
Kate

Hey vpsean, A few things you need to change. First, "Settings->Reading": change it to only show 1 post on the posts page. Second, Go to "WhiteHousePro->Theme Options->Pages and Posts->Post Excerpt Placement" and select "Don't Show." Finally, WhiteHousePro->Theme Options->Pages and Posts->Full Post Content Placement" and select "Show full content on all blog pages"

Share this post


Link to post
Share on other sites
vpsean

Hey Kate, Thank you so much for the reply. You got me on the right track and it's now only showing one post ... Some of the other issues are still there however: 1. I'd like for my posts to show the Facebook commments right away, without having to click anywhere (like you see at www.simpleology.com/blog ) . Currently you have to click 'comments' to get to the reply. 2. The only form of comment response I want to use is the Facebook type ... however, when you click on 'comments,' you see at the bottom both the option for Facebook comments as well as regular comments, which I'd like to have disappear. 3. The 'pagelines' branding is still at the bottom of the posts which I'd prefer to take away. Thanks Kate! --Sean

Share this post


Link to post
Share on other sites
timlinson

Sean, I'm not sure how this will interact with your facebook comment plugin, but you can try disabling comments on pages and posts. Go to the wordpress "Pages" settings and edit any page. Click "screen options" in the top right, which should reveal a "Discussion" section down below when you scroll down. Unset comments. Same deal for posts. As far as removing the branding, the best way to go about it is to contact us via the Contact link. Also, did you modify any of the files manually at some point? You have a standalone brace in the top left of your page.

Share this post


Link to post
Share on other sites
vpsean

Hey Tim, Almost there ... Got the Facebook comments on the home page now through it's FB widget. Can't seem to get the regular wordpress/pagelines 'comments' link off of the page at the bottom though. I followed all your instructions. I'll go ahead and e-mail about the branding ... now with the FB widget on the homepage it's definitely getting in the way. Thanks Tim. --Sean p.s. Any other ideas how to get the 'comments' off of the posts?

Share this post


Link to post
Share on other sites
vpsean

And by the way Tim ... no, didn't edit the file. Not sure why there is a { at the top left of the screen at www.SeanPatrickSimpson.com , though I would like to get rid of it. It's also at the top of my partners website www.SarahProut.com. --Sean

Share this post


Link to post
Share on other sites
vpsean

Hey Tim, I wrote the contact form like you suggested and they're helping me for question number 1 ... We're still trying to figure out what A. The Bracket is doing at the top left of www.SeanPatrickSimpson.com (<-- No I didn't edit the coding at all) and B. How to get the pagelines/wordpress comments link off the bottom of my posts so only the Facebook comments remain. In the e-mail they suggested I come back here for help, but asked if I tried editing Settings/Discussion <-- Yes, I did. I unchecked ''Allow people to post comments on new articles' . I also tried making a new post after doing that with the 'comments' unchecked on that individual post as well ... and still, the comments are there. Thanks! --Sean

Share this post


Link to post
Share on other sites
astearns

For the bracket - if you go to http://validator.w3.org , you'll see that there is a bracket outside of a style tag in Line 32, Column 9 which is probably causing your issue. You will need to remove the random bracket in the code to fix the problem. You can hide the comments link on the bottom of you posts using a little custom css code. If you don't have Firebug, it's an awesome tool that can help you with this. Just select the comments link in Firebug and find the appropriate CSS class, and set it to {display: none;} . Hope this helps! :)

Share this post


Link to post
Share on other sites
vpsean

Hey Alyson, Thanks for much for the response ... I hope you can forgive the fact that I'm a total and complete newbie to anything css :- so I have to ask some more questions on this! 1. Regarding Line 32, Column 9 ... can you tell me specifically where in wordpress/pagelines I would fix this? I'm also semi-new to wordpress as I haven't used in in years ... so if you could explain a way such as "Go to Settings/Wordpress/Editor" etc. for whereever I should be editing. 2. I just got Firebug, and I have absolutely no idea what to do with it or how it works! :- -- When you say, "Find the appropriate CSS class, and set it to {display: none'}" I don't even know where to begin on this ... let alone get my Friebug running!! lol. ...I guess that's where your genius support comes in. Thanks Alyson, I appreciate you. --Sean

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×