Jump to content
Sign in to follow this  
mshack

Unable to hide sidebar on blog/post pages in PlatformPro

Recommended Posts

mshack

I've inspected with firebug and tried every suggestion I could find in the forum, but I'm afraid I'm unable to solve this one. I have a sidebar with a couple of widgets that I only want displayed on the home page, so I've hidden the sidebar on every page except the home page. However, on both the main blog page and the individual blog single-post pages, the hide command is ignored. For the main blog page, one workaround is to choose the full-width layout on the "blog and posts" tab within the PlatformPro settings, but this is a little inelegant, as I want to preserve my column width. Even if this were acceptable, the single-post pages ignore this selection and still display the sidebar widgets. So, I'm wondering if I can preserve my one-right-sidebar layout on these pages and hide the widgets, as I can on my other static pages. Any help would be appreciated. Thanks. The site is still in development and pre-DNS-change, with a temporary URL of: www.riversideschool.dreamhosters.com

Share this post


Link to post
Share on other sites
cmunns

Did you see the there are two checkboxes under the "advanced toggle" where you initially clicked "hide by default" ...you also need to click "hide on posts pages"

Share this post


Link to post
Share on other sites
mshack

Thanks, Adam. I had completely missed those checkboxes, as I was selecting "Hide Primary Sidebar" on the posts and blog main page directly. Thanks again.

Share this post


Link to post
Share on other sites
jasonh1234

Um... where is this "advanced toggle"

Share this post


Link to post
Share on other sites
bill_mccullough

The advanced toggle is located in the templates section under the general Platform Pro settings.Besides a default page, box page, etc, you also have a template setup for each sidebar.... sidebar 1 and sidebar 2.Once you drag and drop a section in the sidebar, you can click on "advanced setup"... located exactly on the section icon you just dropped into the template. Then you will toggle the "hide on post pages" checkbox. I hope this helps someone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×