Jump to content
Sign in to follow this  
fcorella

out-of-the-box error messages

Recommended Posts

fcorella

I just bought the developer version of platformpro, and installed the latest version of wordpress, the platformpro theme and the platformbase child with no content. I activated platformbase and got the following error message, repeated eight times at the top of the page: "Notice: Undefined index: css_prop in /var/www/html/wp-content/themes/platformpro/core/library/class.css.php on line 131". What should I do about this, other than try to get my money back? Francisco

Share this post


Link to post
Share on other sites
Guest Guest

I did a few searches and couldn't find any related issues to this, marking this thread for developer support.

Share this post


Link to post
Share on other sites
Andrew

Hey Francisco, are you running any debugging stuff on your server? Normally notices shouldn't pop up on the front end. Second, which theme version are you running?

Share this post


Link to post
Share on other sites
fcorella

Hi Andrew, So, is it normal to have notices? I don't remember seeing notices when I was trying out the free version of Platform. Now I'm seeinig a bunch in various places. I'm not doing any debugging on the server. I'm using an Amazon virtual server that I've just created for the only purpose of trying out PlatformPro. I've checked php.ini, and error_reporting is set to E_ALL. However changing it to E_ALL & ~E_NOTICE does not make a difference, I still see the same PhP notices. (I did verify that the change took effect by running phpinfo().) I've done a search of the entire document tree, which has the wordpress code and the platformpro and platformbase themes, and I see that wordpress calls the runtime error_reporting() function in many places, but I haven't found any that turns on E_NOTICE. I'm using version 1.2.3 of PlatformPro, version 1.0.4 of PlatformBase and version 3.1 of WordPress. Thanks, Francisco

Share this post


Link to post
Share on other sites
Simon

Do you have `WP_DEBUG` set to true in `wp-config.php`? As this will overide your php.ini settings. Make sure it is commented out or set to false. You can also over-ride php settings adding `error_reporting(0);` The undefined index error is fixed in the dev version.

Share this post


Link to post
Share on other sites
fcorella

You're right, I have WP_DEBUG set to true. I forgot that I set it to true when in configured WordPress. I'm new to WordPress. I've downloaded the dev version again, and the notice I reported earlier is still not fixed. I've run into several more notices, FYI: Notice: Undefined variable: site_title in /var/www/html/wp-content/themes/platformpro/core/library/library.templates.php on line 302 Notice: Undefined variable: metabar in /var/www/html/wp-content/themes/platformpro/core/library/library.templates.php on line 346 Notice: Undefined variable: site_logo in /var/www/html/wp-content/themes/platformpro/core/library/library.templates.php on line 296 I'll set WP_DEBUG to false if I decide to go ahead and use your software. But I'll have to think hard about it, all these notices don't inspire confidence.

Share this post


Link to post
Share on other sites
bryan-hadaway

Amazon Virtual Server? I can't say for sure but that doesn't sound like the right testing environment for a WordPress/PageLines website. Shoot me an email: bryan@pagelines.com Thanks, Bryan

Share this post


Link to post
Share on other sites
Simon
The undefined index error is fixed in the dev version.
I actually meant the development version, soon to be 1.3 ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×