Jump to content
Sign in to follow this  
ericwlee

Very slow Website loading time

Recommended Posts

ericwlee

Hi Everyone, As I've been developing my site, I've noticed both the backend and live loading time of the website has become super slow. At times it will take 30+ seconds to load a page. My site is http://www.ecomv.net I am wondering if it is possible for someone to evaluate my site and advise on how it might be able to speed up loading time? I have cleaned up unused plugins and themes. I've also gone ahead and tried to install the wp-super-cache plugin. I am lost when it says I need to change my permalinks to active the plugin. Will that mess with all the pages I have already created? What other solutions should I be trying? thanks. Eric

Share this post


Link to post
Share on other sites
ericwlee

Also, I've have been playing around with image resolution. Initially, I have been working with very high quality jpegs, but have been optimizing them at a lower quality lately and it hasn't seemed to be making much of a difference.

Share this post


Link to post
Share on other sites
cmunns

The next update does consolidate css files which will help as will getting a caching plugin and compressing all the HTML and continuing to reduct image size.

Share this post


Link to post
Share on other sites
ericwlee

Hi Adam, When will the next update be available? I ended up trying the w3 total cach plugin. I see some default settings checked. Out of the box, there doesn't seem to be any improvement with speed. Any recommendations on what configurations I should be using? Also, could the hosting cause any of problems? We are using Godaddy. Thanks in advance.

Share this post


Link to post
Share on other sites
scottbruzek

Eric, there is a very strong possibility that some of the speed issues with your site could be a GoDaddy issue. I have a client site on GoDaddy that runs wordpress with Platform Pro and frontend load times are 2-3x normal, and admin load times are 4-5x normal. Speaking with the GoDaddy rep, there was excessive traffic on another shared account on the server that was causing the speed issues. Nothing we courld really do about it (aside from upgrading to VPS / dedicated server.) I hope you get the issue resolved.

Share this post


Link to post
Share on other sites
ericwlee

Thanks guys. Bryan - I've just installed the minified plugin you recommended. I don't want to get too excited but, as of now the site seems to be loading A LOT faster. I'm hoping the server is not just have a good moment. Do you think that did the trick? Mind taking a look? http://www.ecomv.net I am really really hoping that the HOST isn't still an issue. Since I have activated the plugin, however, I've noticed that some of the formatting has changed (header tags were green are now black, body copy was gray, now is blue. ) Some of the coding in my Custom CSS section is being ignored now. Any idea why this is happening? Eric

Share this post


Link to post
Share on other sites
Andrew

Eric, might be a caching issue with the plugin... sometimes, they need to be tweaked to work correctly

Share this post


Link to post
Share on other sites
cambridgenaturals

Hi Bryan, How does one exclude the main stylesheet from being minified? Thanks! Emily

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×