Jump to content
Sign in to follow this  
buddhistwhatson

Section Control and Sidebar visiblity issues / problems

Recommended Posts

buddhistwhatson

Hi; I am having trouble with the section control and controlling the display of sidebars. When i set to hide or show the primrary secondary or tertiary sidebars , on sidebar1 and sidebar2, using the page section control, and then update the page - either one of two things will happen; 1) the checkboxes to show or save will change or revert (tickbox selection??‰ 2) the checkboxes will update, but the html page will not reflect these changes I have altered the template setup / hide by default buttons - tried on and off - to no avail,and then used section control to show or hide. I read a previous post about this and reverted to the TwentyTen theme and then activated platform pro base them again. Also to no avail. I then deactivated all of my plugins, and did the theme reactivations again as above, to no avail. The sidebars are empty of widgets ( except for a text widget so i know which sidebar im looking at ( primrary,secondary or tertiary). Currently i cannot see the secondary sidebar even though it is set to show in the home page section control and has the text widget in it. So i cannot control the sidebars. and presently the secondary sidebar will not display on the home page, whatever i do. I tried it on other pages, example, with mixed results,On the blog page i could display sidbar2 secondary sidebar, but on the fax page i could not. Please help, this has stopped the development of our site completely. Also, im in Australia, and dont seem to catch you when u are there. Can you tell me your location and hours of support. My site is www.buddhistwhatson.com . password is Happy666 Thanks

Share this post


Link to post
Share on other sites
cmunns

Hey Rodney, It would be extremely helpful if you could show the corresponding options you have set for a given "broken" page. Maybe even a screencast of both the template setup and the section control on that page. This will prevent both of us from looking for a needle in a haystack if i can see exactly what you have back there.

Share this post


Link to post
Share on other sites
buddhistwhatson

hi; if you send me an email to yooky6@gmail.com , i will reply with our wp-admin password and you can take a look for yourself. ok?? Thanks

Share this post


Link to post
Share on other sites
bryan-hadaway

My apologies... I meant the contact page. Anyways, I have the details and am checking now... Thanks, Bryan

Share this post


Link to post
Share on other sites
buddhistwhatson

Hi; i ended up having to re-install the wordpress core for another unrelated issue. Afterwards the issue of the sidebars had resolved itself. Hopefully it does not return. Thanks for you help guys

Share this post


Link to post
Share on other sites
buddhistwhatson

hi. the problem of the sidebars has returned again.Same as before I set the home page with "two sidebars on right" and then populated it. After that , i set the sidebars to appear in sidebar1 and sidebar2, then a few things happen; - when i set the sidebar options in section control and save, they may stay the same or change in a way not set by me. example; if i enable tertiary sidebar in sidebar one, and disable in sidebar 2, after updating, they will both be on or off - or , they may all enable. - The sidebar2 will not display in the home page, and if i keep changing the control settings, for example to exclude the secondary sidebar in sidebar2, then sidebar2 may re-appear, but the control section will still behave erratically- and in this case the tertiary sidebar will appear in sidebar1 and sidebar2 , even though it was enabled in sidebar2 and disabled in sidebar1. -I tried the theme disable re-enable, no effect, -I have the latest platform pro, and am using child theme -I have just disabled all plugins , and reset theme again - no luck. -Disabled the ajax saving. - set dynamic.css to 666 I,m getting a little frustrated here , as i cannot even get the basic layout on the site setup. The last time this happened, it was fixed by installing fresh core of wp3.1 and a your newest pp. Obviously i cannot do it everytime. So the bottom line is i cannot save section control settings, and the display of sidebar2 is unreliable. I know this seems like a tricky one, but i need your help. site is www.buddhistwhatson.com thanks

Share this post


Link to post
Share on other sites
bryan-hadaway

Okay, marking for developer review. Thanks, Bryan

Share this post


Link to post
Share on other sites
buddhistwhatson

hi, i also set inline css in the misc settings,no luck i commented out all my css settings in base.css i noticed that dynamic css has not been updated since the 4th of this month. still cannot save. please send an email to me at yook6@gmail.com if you want admin access to the site thank you

Share this post


Link to post
Share on other sites
bryan-hadaway

Rodney, We won't email you. If you can't share a public link you need to contact us with the login info and reference back to the topic so support knows what it's about: http://www.pagelines.com/contact/ Thanks, Bryan

Share this post


Link to post
Share on other sites
buddhistwhatson

Bryan; What does developer review mean? Does it mean that someone will look at it presently? I'm starting to doubt going down this road, as i cant even get a basic site going. If they are able to help they can access . bwowp Happy666 thanks

Share this post


Link to post
Share on other sites
cmunns

Rodney I took a look and the problem is that you are trying to use multiple instances of the same sidebar e.g. (secondary sidebar) in two different template areas e.g. (Sidebar1 and Sidebar2) when you check the section control box to hide/show it won't change because you have the two instances. Instead you need to use a different widget area.

Share this post


Link to post
Share on other sites
buddhistwhatson

Hi; oh i get it, i think. i thought i could add all of the sidebars Pr,Se,Te etc to sidebar1 and sidebar1, and then turn off the Pr??? Se, or Te in page control. Is this wrong? Just want to get it straight. thanks

Share this post


Link to post
Share on other sites
cmunns

Right now it's not setup to handle multiple instances of sections on the same page.

Share this post


Link to post
Share on other sites
buddhistwhatson

hi; ok thanks, that was so confusing for me. Should i have known that already? If so, my apologies for wasting your time thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×