Jump to content
Sign in to follow this  
joeclinegmailcom

Issues with WhiteHousePro 3 navigation being overridden

Recommended Posts

joeclinegmailcom

For some reason my whitehouse pro 3 website won't completely abide by my Theme settings for Navigation. I looked in the Header.php file and turned off the navigation items in the theme settings, but the links for sub-pages are still being written, but in the format of " <li class="page_item page-item-24"><a href="http://www.affinityproperties.com/selling.php" title="Sell">Sell<ul class='children'><li class="page_item page-item-80"> " I googled the page_item page-item- and found that it appears to be a way that wordpress writes out navigation, but shouldn't the theme take over this functionality? Any ideas on how I can fix this?

Share this post


Link to post
Share on other sites
kastelic

Could you post a link to your site, and try to give us an idea of exactly what you want to accomplish? Editing header.php is kind of a last resort. There's a lot you can do before you try that.

Share this post


Link to post
Share on other sites
joeclinegmailcom

crap. Sorry for the late response. I didn't get an email saying there was a response. I'm trying to optimize my site and a google analysis tool is saying that there are too many (over 100 links) per page. When I look at them most of the links are secondary nav, which I have disabled as dropdowns so shouldn't need to be on any page except when they are the child of the current page. Additionally, it's bloating the html with a lot of page_item links that don't need to be there. my url is www.affinityproperties.com. Thanks a ton.

Share this post


Link to post
Share on other sites
joeclinegmailcom

Not really. The way google address pagerank sculpting was the basically take the PR of the page, divide by the number of links and then pass 0 PR to nofollowed links. It used to take PR and divide by the number of non-nofollow links, thus you could do something with the PR. Now if you hvae links that are no-follow the PR just evaporates. It would be nice if I could just get the links not to be generated in the HTML. The links never show up in navigation unless you are in a child of the current page anyway so why send the children of other parents to the browser? Seems like poor design and SEO. Joe

Share this post


Link to post
Share on other sites
Kate

Hey Joseph, I think something Adam mentioned will help you... If you use a custom menu (Appearance->Menus) then you won't have to have the sub menu items automatically appear. If you want to have sub menu items, you can manually insert them.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×