Jump to content
Sign in to follow this  
buddhistwhatson

adjust page content area spacing

Recommended Posts

buddhistwhatson

Hi; I'm using platform pro. I was trying to put a colour behind the nav menu, so i copied a code from one of the posts and put it into custom css. Here is the post - Change Platform Pro main navigation bar background color Posted 5 days ago by Kevin Johnson so i used the code, Add the following CSS to the "Custom Code" in Platform Pro>Settings>Custom Code (This is all of it, so you can adjust as needed): ----------------------------------- #primary-nav {background: #151B8D;} #primary-nav li a {background: #151B8D;} #primary-nav #nav_row {border-bottom: 0px solid #151B8D;} #primary-nav .main-nav li a:hover{ background: #fff; color:#151B8D; font-weight:lighter; } .main-nav li.current-page-ancestor a, .main-nav li.current_page_item a, .main-nav li.current-page-ancestor ul a, .main-nav li.current_page_item ul a{ background: #151B8D; color: #fff; font-weight:lighter; } #primary-nav ul.sf-menu a, .sf-menu a:visited { color:#fff; font-weight:lighter; } #primary-nav ul.sf-menu li a { padding: 7px 15px; color:#fff; font-weight:lighter; } #primary-nav li a{ font-size: .8em; } ------------------------------ and it worked wonderfully. However then i noticed that a slider shortcode that i had in the content area moved down from the top so that a gap appeared. I used firebug to try to fix it but it doesn't work, i also tried this code, but to no avail .mcolumn-pad { padding-top: 0em; If i remove the first code - to change nav colour then my image moves up into the default position. Here is the code in the content area <p style="padding-top:-10px;"></p> <table style="margin-left:0.5em;"><tr><td> [FrontpageSlideshow fs_cats=39 fs_slides=7 fs_show_buttons=0 fs_main_width=580px fs_main_height=180px fs_slide_width=85% fs_buttons_width=15% fs_rounded=0 fs_template=default] </td></tr></table> the site is www.buddhistwhatson.com - password is Happy666 please help. thank you in advance

Share this post


Link to post
Share on other sites
Kate

Hi Rodney - I'm taking a look at it... It almost appears that it's just an optical illusion. The slider is indeed moving down, but that's because you're changing the font-size and padding with the nav. Could you just change the CSS for the slider to move it back where you want it? It looks like currently you're using a paragraph tag with padding for styling, which obviously isn't optimal.

Share this post


Link to post
Share on other sites
buddhistwhatson

Hi kate; Thanks for your reply. I removed the padding in the html, but nothing changed. Then i tried to adjust the padding in the nav code, #branding .content-pad { padding: 15px 25px 13px; When i changed these values nothing changed, (of course it may be nothing to do with the problem). How can i adjust the css of the slider, or is there any thing else i can try? Could you please tell me how to do that? Thank you Thanks

Share this post


Link to post
Share on other sites
bryan-hadaway

Everything looks great... perhaps you already fixed this? Thanks, Bryan

Share this post


Link to post
Share on other sites
buddhistwhatson

Hi Bryan; Yes it seems ok now, but i dont know what i did! haha, well at least im learning... i hope. thanks for your help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×