Jump to content
Sign in to follow this  
alamink

Page comments on iBlogPro

Recommended Posts

alamink

Hello - I have enabled comments on some pages as well as the blog. However, on the pages, the comments section does not show up (even when there are comments). Strangely, it does show up on the mobile version of the website. Any idea how I can get the comments to appear on the pages where they are enabled? Thanks!

Share this post


Link to post
Share on other sites
bryan-hadaway

Maybe a link to a page that successfully shows comments and then a link to one that is failing. Also, did this just start happening recently after a change perhaps? Thanks, Bryan

Share this post


Link to post
Share on other sites
alamink

Hi Bryan - This is a post where the comments work fine: http://vijana.fm/2011/02/09/pen-mic/ (usually, no problems occur with commenting on blog posts) Here is a page where comments are enabled, but they do not appear on the regular web page (but they do appear on the mobile web page): http://vijana.fm/about/projects/bila-sanaa/ Can't think of any recent changes relating to comments that I might have made. Until now, I was under the impression I just had to enable comments/pingbacks by the checkbox options below the edit-post page. Any help would be appreciated! Thanks again. Cheers, ak

Share this post


Link to post
Share on other sites
cmunns

I'm guessing it's related to the music player you have on the page where comments aren't showing up. Likely incorrect markup for embedding it. To test this, try removing this music player and see if the comments appear again.

Share this post


Link to post
Share on other sites
bryan-hadaway

Okay, check your Template options and make sure you dragged comments in the page area. Thanks, Bryan

Share this post


Link to post
Share on other sites
alamink

Thanks, Bryan. Though I'm not sure which Template options you are referring to? Sorry!

Share this post


Link to post
Share on other sites
catrina

Go to Settings > Template Setup. From the dropdown list, select Page Content Area and drag the Comment Area box from the right to the left to enable it.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
alamink

@Bryan and @Catrina I don't seem to be seeing the options you guys see for Template Settings anywhere on my dashboard panel. iBlogPro - or at least the version I'm using - doesn't seem to have an option to drag and drop page elements... Thank you for your consideration, ak

Share this post


Link to post
Share on other sites
Guest Guest

What plugins are you using on your site? I know it sounds strange but sometimes plugins can cause strange conflicts like this. Disable all plugins temporarily and see if the issue persists. If this fixes it, you'll have to enable each plugin one by one to see which one is causing the issue.

Share this post


Link to post
Share on other sites
alamink

@Tyler thanks for the suggestions. Tried that and none seem to be affecting the commenting option on pages. This might be an ever stranger shot at this, but could it be that something is missing on template_page.php? Here is what I have for that file:

<?php if(pagelines('featureboxes', $post->ID) && VPRO) require(PRO.'/template_fboxes.php');?>
	<!-- Standard Page Code -->
	<div id="maincontent">
		<div id="content">
	
			 <?php require(THEME_LIB.'/_posts.php');?>
	
		</div> <!-- end content -->
	</div>
	<?php get_sidebar(); ?>
	<!-- End Standard Page -->

Share this post


Link to post
Share on other sites
alamink

Sorry for the delayed response, but I see niether of those files, Catrina (template.content.php or template.php). Thanks for your persistence.

Share this post


Link to post
Share on other sites
catrina

There is no such file as template_page.php in the iBlogPro theme folder. Can you double check to see if that's the file name?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
alamink

I see a template_page.php, and this is what's in it:

<?php if(pagelines('featureboxes', $post->ID) && VPRO) require(PRO.'/template_fboxes.php');?>
	<!-- Standard Page Code -->
	<div id="maincontent">
		<div id="content">
	
			 <?php require(THEME_LIB.'/_posts.php');?>
	
		</div> <!-- end content -->
	</div>
	<?php get_sidebar(); ?>
	<!-- End Standard Page -->

Share this post


Link to post
Share on other sites
bryan-hadaway

Sorry, my apologies. What I was describing is possible in PlatformPro. But, you are on the right track. Go back to the template_page.php page: Appearance > Editor > template_page.php and just below this line: `<?php require(THEME_LIB.'/_posts.php');?>` add: `

<?php comments_template();?>
` Thanks, Bryan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×