Jump to content
Sign in to follow this  
thomas_c

meta security concerns

Recommended Posts

thomas_c    0
thomas_c

hi guys, i noticed that meta tag "generator" is defined twice. see your source code, you'll know what i mean. my take is, the generator tag shouldn't be in the source at all. i removed the tag generated by the wp core. how would i remove the second generator tag created by platformpro? tom

Share this post


Link to post
Share on other sites
Andrew    201
Andrew

Hey Thomas, what meta generator are you talking about? If it's on our end we'll check into it..

Share this post


Link to post
Share on other sites
thomas_c    0
thomas_c

Hi Andrew, my header looks like this: notice the 2 <meta name="generator" tags.

<link rel="shortcut icon" href="http://localhost:8888/wp-content/themes/platformpro/core/images/favicon-pagelines.ico" type="image/x-icon" />
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	[b]<meta name="generator" content="WordPress 3.0.4" />[/b]
	<link rel="pingback" href="http://localhost:8888/xmlrpc.php" />
	<!--[if IE 6]>
	<script src="http://localhost:8888/wp-content/themes/platformpro/core/js/ie.belatedpng.js"></script>
	<script>DD_belatedPNG.fix('.pngbg, .shadow-bottom, .post-comments a, #fcolumns_container, #footer img, .branding_wrap img, .fboxgraphic img ');</script>
	<![endif]-->
	<meta name='robots' content='noindex,nofollow' />
	<link rel="alternate" type="application/rss+xml" title="My Site ?» Feed" href="http://localhost:8888/?feed=rss2" />
	<link rel="alternate" type="application/rss+xml" title="My Site ?» Kommentar Feed" href="http://localhost:8888/?feed=comments-rss2" />
	<link rel='stylesheet' id='pagelines-pro-css'  href='http://localhost:8888/wp-content/themes/platformpro/pro/pro.css?ver=1.2.1' type='text/css' media='all' />
	<link rel='stylesheet' id='pagelines-stylesheet-css'  href='http://localhost:8888/wp-content/themes/platformbase/style.css?ver=1.2.1' type='text/css' media='all' />
	
	<link rel='stylesheet' id='pagelines-dynamic-css-css'  href='http://localhost:8888/wp-content/themes/platformpro/core/css/dynamic.css?ver=1.2.1' type='text/css' media='all' />
	<!--[if lte IE 6]>
	<link rel='stylesheet' id='ie6-style-css'  href='http://localhost:8888/wp-content/themes/platformpro/css/ie6.css?ver=1.2.1' type='text/css' media='all' />
	<![endif]-->
	<!--[if IE 7]>
	<link rel='stylesheet' id='ie7-style-css'  href='http://localhost:8888/wp-content/themes/platformpro/css/ie7.css?ver=1.2.1' type='text/css' media='all' />
	<![endif]-->
	<script type='text/javascript' src='http://localhost:8888/wp-includes/js/jquery/jquery.js?ver=1.4.2'></script>
	<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://localhost:8888/xmlrpc.php?rsd" />
	<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://localhost:8888/wp-includes/wlwmanifest.xml" />
	<link rel='index' title='My Site' href='http://localhost:8888' />
	[b]<meta name="generator" content="WordPress 3.0.4" />[/b]
	

Share this post


Link to post
Share on other sites
thomas_c    0
thomas_c

thanks bryan, i know the plugin. the problem is, it just removes one of the tags. i think it has something to do with either the base theme, or the platform pro head. any ideas? tom

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×