Jump to content
Sign in to follow this  
cefisher

Duplicate widgets in sidebar

Recommended Posts

catrina

Hm, it looks like that the entirety of the Primary Sidebar is duplicated, not just the two widgets inside of it. What changes did you make to the CSS and/or any other theme files?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
cefisher

I have not made any CSS or custom theme changes.

Share this post


Link to post
Share on other sites
Andrew

In the Template Setup area did you happen to use the Primary Sidebar twice?

Share this post


Link to post
Share on other sites
cefisher

I checked the template setup area and I did not use the primary sidebar twice. What next? Thank you for the help.

Share this post


Link to post
Share on other sites
Kate

Hi Coleman - I just want to recap here, just in case, because the sidebars have two different IDs, meaning they're being generated from two places. In "Settings->Template Setup", under "Posts Pages", "Single Post Page", or "Default Page" you don't have "Universal Sidebar" in the left column?

Share this post


Link to post
Share on other sites
cefisher

No... I do not have universal sidebar in the active column in posts pages, single post page or default template. Thanks Coleman

Share this post


Link to post
Share on other sites
bryan-hadaway

Until you figure out what settings were set incorrectly here's a surefire way to fix this problem now: `#sidebar1{display:none}` Add to Custom Code > Custom CSS. Thanks, Bryan

Share this post


Link to post
Share on other sites
cefisher

I do not what to hide the sidebar...I just don't want a duplicate sidebar. What should I do next? I will be glad to give one of you my username and password so you can look around the backend if need be.

Share this post


Link to post
Share on other sites
cmunns

It's weird because I can see on your site that they are both part of the "Primary Sidebar" widget, but only one is wrapped inside of the SIDEBAR 1 template area whereas the other (top one) shouldn't be there. Is there a setting in the nextgen options for adding a gallery widget that you may have pressed. Any insight into the options you've set would be helpful

Share this post


Link to post
Share on other sites
cefisher

I dont think it has to do with the settings in nextgen because any widgets I add to the primary sidebar are duplicated. I have removed all widgets one by one and then re-added them: same issue. No matter what I seem to do all widgets are duplicated. I even restored the settings back to default. What next?

Share this post


Link to post
Share on other sites
cmunns

Do you have any other plugins installed that you can test by turning off, or is it possible to re-install? I've never heard this before, what other information can you provide and have you tried testing in a different environment?

Share this post


Link to post
Share on other sites
cefisher

Ok, I have removed all widgets from all sidebars, and then I added the calendar widget that displays when posts were updated. No matter what widget I place in the sidebar it is duplicated on the site. I checked the settings in the layout editor and confirmed the sidebar is not in the active area twice, and in fact it is not even in the active area at all for the selected page type. However, on the site, the sidebar displays widgets twice. What should I do?

Share this post


Link to post
Share on other sites
bryan-hadaway

Again Coleman, Try my solution: `#sidebar1{display:none}` It isn't to hide everything, just the duplicated sidebar, if it's not working let me know how it's not working and we'll try something else. Thanks, Bryan

Share this post


Link to post
Share on other sites
cefisher

If I hide the duplicated sidebar with the code above will it slow down the site becuase there are multiple widgets running? Is this a long term solution or a temporary fix? Thanks

Share this post


Link to post
Share on other sites
Andrew

coleman it looks like you have the primary sidebar in the 'sidebar_wrap' area...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×