Jump to content
Sign in to follow this  
bansuriflute

Hidden Pages Show Up in bbPress Navigation

Recommended Posts

bansuriflute

I just installed bbPress with Platform Pro theme. Everything is working fine except the hidden pages show up in site nav. If you see the main wordpress nav (www.bansuriflute.com) and bbPress nav (www.bansuriflute.com/discussions) the bbPress nav shows many more pages that are supposed to be hidden. Am I doing something wrong? Prasad

Share this post


Link to post
Share on other sites
bansuriflute

I used plugin called "Exclude Pages from Navigation". It works well with the main site but does not seem to work with bbPress. I am perfectly willing to use any other way to do this if necessary.

Share this post


Link to post
Share on other sites
cmunns

There is no need for a plugin. I recommend digging into the menu system built into the latest versions of WordPress. APPEARANCE - MENUS gives you full manual control over what pages show up, in what order, and as drop downs of what parents.

Share this post


Link to post
Share on other sites
bansuriflute

I tried that. If I use custom menus - 1. I lose the "drop down" behavior. 2. I will have to maintain menus every time I add pages. Anyway, for now I have disabled bbPress since I was having some other cookie related issues. Will figure this out later.

Share this post


Link to post
Share on other sites
bansuriflute

@Adam, @Kate - I played around with the menus some more and it indeed works as Adam suggested. However, given the number of pages I have (and will likely have when it is all said and done), it will be pretty painful to remember to add the pages to custom menus. Automatic site navigation menu in the main site is working pretty well for me. Is there any hack I can use to just make the bbPress theme replicate what main site is doing? I will really really appreciate if there is a way to do this.

Share this post


Link to post
Share on other sites
cmunns

well we can't fix the plugin but we could hide those menu items manually with some CSS, but that's not a real clean solution either.

Share this post


Link to post
Share on other sites
bansuriflute

Ok. Did more research and I think I am getting closer. My bbpress forum was installed at www.bansuriflute.com/discussions. I tied it up to buddypress group forums. Now the information I am getting at the forum above and at buddypress group forum link (http://www.bansuriflute.com/forums/) is identical. Therefore I don't really need to access www.bansuriflute.com/discussions anymore. This solved two problems immediately. 1. The menu is as it needs to be (great!!) 2. I was not getting buddypress admin bar at the bbpress page. Now I am getting even that (yey!!!) Only question now is - Is there any way to apply the platformforum theme to the group forum? As you can see that theme is very clean compared to buddypress group forum. Almost there!! :) @Adam, help!!!

Share this post


Link to post
Share on other sites
bryan-hadaway

No, not in a traditional sense could we apply a bbPress theme to a BuddyPress theme. Basically, were looking at: http://www.bansuriflute.com/forums/ And if you explain specifically how you'd like us to apply styles; colors, fonts etc. we can help. We can't make it just like bbPress though as there are different functions, they are different software. Thanks, Bryan

Share this post


Link to post
Share on other sites
bansuriflute

Thanks Bryan. I think some minor tweaks will help. Here's the list - 1. "Search Anything" text area should be aligned with Search button and both these should be in the same line as Group Forums Directory. 2. New Topic button should have black background. 3. "Latest poster" and "Posted in Group" should be consistent in Avatar size. 4. Font size for both the above should be bigger. 5. Font size for number of posts should be bigger. 6. Under forum index, forum description should be in smaller font than forum name. 7. Topics, posts and member count should be bigger in font. 8. Avatar and name for last post column should follow the same format as 3 above. 9. In the first line of forum index, Social media tags are mixed up. Those tags should at the bottom of the page. Guys - sincerely appreciate help around this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×