Jump to content
wendygordon

Header: "Using a Theme Header"

Recommended Posts

wendygordon

Hey Pagelines.

The weirdest thing... I was just informed that my site doesnt have a menu on it.  - it used to!  And when I went to look, I noticed that there was NO menu in the header section.  Instead, a greyed out message saying "Using a Theme Header" ( I am using a starter child  theme) and I cannot drag anything into the header section.  http://www.workproductions.com   Ideas?

Share this post


Link to post
Share on other sites
wendygordon

Update.  I added a meganav to the template section, on the home page, just so I have some navigation, but I cannot add anything into the header section. 

 

Share this post


Link to post
Share on other sites
edgarcheverier

Hi, I Just visited your website, and I can see that you have content on the header section: https://cl.ly/0F0i1p3e2g11

Share this post


Link to post
Share on other sites
wendygordon

Yes.  This information WAS in the Menu section - I think I was using NAV.  the tag line  BUT now I cant edit the header or ADD any section to it.   

Share this post


Link to post
Share on other sites
wendygordon

To be clear.  Last week there was a Menu Section in the header - formatted with information and a menu.  Now there is not. AND the Header area is greyed out - the data that used to be in the menu section is still there.  AND i cannot add or change it. 

Share this post


Link to post
Share on other sites
wendygordon

Anyone?  I am desperate to figure this out!!

Share this post


Link to post
Share on other sites
edgarcheverier

You can use CSS in order to remove the header: https://cl.ly/0W2I1N1J1i1l 

div#header 
 
display: none;

}

Share this post


Link to post
Share on other sites
wendygordon

no..  I guess I am NOT explaining this well.   I am not able to move anything into the HEADER area.  I cant drag and drop a menu in there like I should be able to.  There used to be a menu in the Header area - with text, a logo and a functioning menu.  it has suddenly disappeared and replaced by a greyed out message that says  ""Using a Theme Header""  and the information that is now displayed in the header is the information that I put into the Nav Menu - (that is NO LONGER there).  and I have no way to access the information, delete it or add a menu to the header.   

Share this post


Link to post
Share on other sites
wendygordon

Edgar - thanks, but I do not think you understand.  I do NOT want to remove the header.  I want to put the menu back in the header, just where it used to be.   I cannot drag anything into the header area.  I cant modify it.  

 

Share this post


Link to post
Share on other sites
Aires

Hi @wendygordon,

Are you 100% sure you are using the framework theme. 

Because if you are not the header and footer will not be available to you.


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
Aires

Ok I did a check on your site and it says you are using the framework theme.

Note that the only time you should see theme header message is when you are using a theme other than framework.

in which case the theme header and footer can not be modified unless you modify the header/footer.php as stated in the docs.


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
wendygordon

thanks so much.  yes.  as i mentioned - i am using the child theme.  AND - the menu was in the header - alive and working well for almost 6 months. suddenly disappeared and suddenly not working.  i did not modify any php files. 

Share this post


Link to post
Share on other sites
Aires

Is this child theme one you created or the PageLines version.


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
wendygordon

it is a plain vanilla, unchanged Pagelines version.  For 6 months it was fine.  I havent been in the files havent touched anything.  suddenly the theme will not let me into the header. 

Share this post


Link to post
Share on other sites
Aires

There may have been some changes to the child theme if it was updated ... I never use the PageLines version because it adds a lot of unnecessary files. I would start there ... by seeing if things work with just the framework theme ( note that this may screw up your custom sidebars if. you have any ).


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
wendygordon

i thought of that, but was afraid of losing all of the front end data.  

 

Share this post


Link to post
Share on other sites
Aires

can you clone the site and try there first via backup

 


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
wendygordon

i can try.  but honestly I do not have time for this.  anyone out there avail for a bit of freelance troubleshooting?  This is gonna take a bit to fix I think!

Wendy

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×