Jump to content
glyph.marketing

Mixed Content from PL extensions messing up SSL

Recommended Posts

glyph.marketing

Hello, 

My team and I are having trouble obtaining full SSL encryption on our site (www.glyphservices.com) due to the presence of mixed content. I believe this is due to the fact that a few pagelines extensions are running scripts that are bringing in files (check.svg and default-image.png) over unencrypted http:// as opposed to https://. See below for examples of the code that I believe is messing me up:

<div class="pl-image top" data-bind="plbg: image, class: $root.image_format" style="background-image: url(&quot;http://www.glyphservices.com/wp-content/plugins/pl-section-boxes/check.svg&quot;);"></div>

<div class="the-fly-quote pl-trigger current-quote" data-bind="plattr: { 'data-image': thumb }" data-image="http://www.glyphservices.com/wp-content/plugins/pl-platform/engine/ui/images/default-image.png" style="opacity: 0; left: -25px; z-index: -1;">
          <div class="pl-quote">
            <p data-bind="pltext: text" class="pltext" data-cedit="text">"placeholder"</p>
          </div>
          <div class="pl-cite pltext" data-bind="pltext: cite" data-cedit="cite">placeholder</div>
        </div>

These bits of content are generated automatically by the Pagelines FlyQuotes and Pagelines Section Boxes extensions, so I can't just go in and change the links myself, and I lack the technical depth to figure out whether there are php parameters that I can change. You can see that the files that are being loaded are coming from my own server but I don't see a way that I can change that link to https because they are being loaded by scripts. 

I would appreciate any input. Here is the link to the explanation in whynopadlock: https://www.whynopadlock.com/results/047196cd-b649-4d88-966f-cd78c71d6983

Thanks!

Share this post


Link to post
Share on other sites
edgarcheverier

Hi,
If you are having problems with the SSL encryption, First try to use Really Simple SSL from WordPress.
If that doesn't work put in contact with your Host and explain that you are having problems with SSL certification.
If you got the certificate with them, there should not be any problem in solve this.

Thank you!

Share this post


Link to post
Share on other sites
glyph.marketing

Hi Edgar, the problem is not with the certificate. We are managing the cert ourselves and it's fine. The problem is with the Pagelines extensions, not with Wordpress. I would like to fix this in Pagelines, not by uploading yet another plugin to my system. 

Share this post


Link to post
Share on other sites
edgarcheverier

Hi,
You can use Really Simple SSL and after use it, you can delete it.
Another option if that doesn't work, is using the Better Search Replace plugin.
You can search for this images:
http://www.glyphservices.com/wp-content/plugins/pl-section-boxes/check.svg
and replace it for:
https://www.glyphservices.com/wp-content/plugins/pl-section-boxes/check.svg

and again after use the plugin you can delete it.

Share this post


Link to post
Share on other sites
glyph.marketing

Edgar, I believe that you do not understand my problem. Look what happens when I do a search for that URL string: 

5a6132d294248_ScreenShot2018-01-18at3_49_25PM.png.c6f673fac6138c62a1095a4fb0e8e84c.png

This URL does not exist on any page and the images in question aren't residing on a page. Something in Pagelines is loading those images from the server. I can't change the URL within Wordpress

Please stop recommending Really Simple SSL and listen to what I am saying. Unless you have a reason to back up your suggestion that, on the surface, appears irrelevant, then stop wasting my time. 

Share this post


Link to post
Share on other sites
edgarcheverier

go to wp-config.php file and add this command:
define('FORCE_SSL_ADMIN', true);

Also in your database in SQL run this code:
UPDATE wp_options SET option_value = replace(option_value, 'http:', 'https:');

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×