Jump to content

Recommended Posts

jharri74

Hello, I want to create a form where a visitor can submit content/post from the front end. I did something very similar some years back using wp-types, CRED form with pagelines DMS. When i try to set this up in Platform 5, the CRED form generates but doesn't show. I get a blank page. In the browser's console window, i get the error: Uncaught Error: You cannot apply bindings multiple times to the same element.

When i deactivate the PL plugin and change the theme, the form appears.

I'm using Wordpress 4.8.2 and PL 5.1.7

Thanks.

Share this post


Link to post
Share on other sites
edgarcheverier

Hi, why you don't try to use the Contact Plugin of PageLines?
It is very good and you can add and modify all the content.
anyway, Can you please attach your website link and a screenshot of the problem? 
Thank you! 

Share this post


Link to post
Share on other sites
edgarcheverier

Sorry for the delay I was trying to find the problem.
I searched for the console error ( Uncaught ReferenceError: wptValidationForms is not defined ).
And I found in the support of wp-types the same issue.
seems like you have to exclude the validation.js script from the scripts to be deferred.

The plugin is creating JavaScript errors with PL5 
https://wp-types.com/forums/topic/uncaught-referenceerror-wptvalidationforms-is-not-defined-2/

 

Screen-Shot-2017-10-24-at-12.10.12-PM.pn

Share this post


Link to post
Share on other sites
jharri74

Thank you but I am not sure how to do that.

Share this post


Link to post
Share on other sites
jharri74

Thank You. I did check the Enable Plugins Script Loading and still getting the same results. I have a ticket open with WP-TYPES with the info you provided. We'll see what happens.

Share this post


Link to post
Share on other sites
edgarcheverier

Great, I also will try to find the solution to this problem, but it repeats a lot in the WP-TYPE forum so probably it is a common problem of the plugin.

Thank you! I hope we can find the solution soon.

Share this post


Link to post
Share on other sites
jharri74

So far it was suggested that I change the head.php file to:

<?php pl_standard_head(pl_edit_head()); ?>
<script type="text/javascript">var wptValidationForms = wptValidationForms || [];</script>

 

and now it also suggested that there is another error coming from common.js (pl-platform/engine/ui/js). Can this file be dequeued or disabled? At least to test?

Thanks.

 

Share this post


Link to post
Share on other sites
jharri74

I do have the latest version of the plug-ins. There's nothing we can do about the error coming from common.js ?

 

Thanks.

Share this post


Link to post
Share on other sites
jharri74

Hello, any thoughts on the above post?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • MrFent
      By MrFent+
      I wanted to share something I'm dealing with on my PageLines 5 website. The website is culturedfoodlife.com. I've seen this issue a few times, but it's always fixed itself without me really doing much, so I don't know how to troubleshoot. It'll start out with my page loading all wonky, due to scripts and stylesheets missing. I look at the page source, and towards the top, I see this line:
      <link rel='dns-prefetch' href='//www.group-ib.ru' />
      I have no idea what that website is, or why it's loading that line of code, and then further down, I see it again as the domain that tries to load all of my pagelines section style scripts:
      <link rel='stylesheet' id='pl-pins-css' href='https://www.group-ib.ru/…/plugins/pl-section-pins/style.css…' type='text/css' media='screen' />
      <script type='text/javascript' src='https://www.group-ib.ru/…/pl-sect…/script.infinitescroll.js…'></script>
      <script type='text/javascript' src='https://www.group-ib.ru/…/plugi…/pl-section-pins/isotope.js…'></script>
      <script type='text/javascript' src='https://www.group-ib.ru/wp-conte…/…/pl-section-pins/pins.js…'></script>
      Here's a screenshot: https://www.screencast.com/t/Nqk9YglUf
      So I get that this is why it's not displaying correctly on the front end, because these style scripts don't exist on group-ib.ru, and I have no idea why it's inserting group-ib.ru instead of my domain culturedfoodlife.com.It makes me think I'm being hacked. This seems to be affecting the styles and scripts of pagelines sections. Other plugins on my site load their scripts with the correct domain name.
       
      When I've seen this in the page, it usually fixes itself after a few minutes, but in this last case, it didn't fix itself until I started disabling plugins. I was trying to see if I could go through each plugin one by one to see if I could fine out anything. I disabled everything but all my pagelines plugins/sections, and the issue went away. Then when I re-enabled everything, the issue was still gone. So now I'm clueless as how to keep testing this. Any suggestions?
      The fact that disabling every plugin EXCEPT the pagelines plugins kind of make me think that the issue isn't with pagelines, but then again when the issue occurs, why does it only affect pagelines sections? Andrew Powers I could use some insight. Thanks.
    • petere21
      By petere21
      After activate new web site
      I had several licences for use but system show me that I have no licence 
    • petere21
      By petere21
      When i see wp content,i have no margin from left and right side means bordee on tablet view
      mobile margin around wpcontent is fine dtp also ok it looks like spread enough  on tablet - ipad - there is no margin and text from left side and widgets from tight side content sticking border of monitor how could i fix margin for example 5px for tablet view? But without changing the mobile margin 
      Sample https://www.restartnisa.sk/poloniny-po-zemplinsky/
      thanks 
      petere
    • petere21
      By petere21
      Does pagelines support AMP technology for mobiles?
       
    • petere21
      By petere21
      How to control spaces between images ?
      I can control section  padding from left and right side but not between  images.
      Could someone help me?
×