Jump to content
abeedle

[Solved] MegaNav Opacity on Hover/Selected

Recommended Posts

abeedle

It appears that within the default settings for MegaNav menu items are slightly opaque when they are not selected or hovered over. Then on the selected page and on hover of the menu item opacity goes to 1. It's not a big deal in most cases but we are including a button on a client's menu and the white text just doesn't stand out as well unless you are on the page itself and the opacity has changed to 1.

My question is whether there is a way to essentially flip the default settings so that when a menu item is not selected/hovered over the opacity is 1 and when the page is selected/on hover the opacity is slightly less than 1.

I assume the fix would be by using custom CSS and we have tried a few different methods of attempting to target the menu opacity without success.

Any help would be greatly appreciated! Thanks!

Share this post


Link to post
Share on other sites
Ray

You can achieve this with custom css, something like this: 

.pl-sn-meganav .meganav-menu > li > a{
	opacity: 1;
  
  	&:hover{
  		opacity: .7;
  	}
}

 

Share this post


Link to post
Share on other sites
abeedle

Worked like a charm - thanks so much Ray!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • mtaus
      By mtaus+
      I'm using MegaNav on this site and the menu items and logo are "sticky" (which I selected), but the background scrolls. 

    • oseehys
      By oseehys+
      Hi @raylonet @Aires Dagraca A. Hey Guys, if i can fix this i wont be here, please help out here.
      I am trying to align some of my menu Items to the right, as it is on Pagelines website, Pagelines is using Navpro, i am aware.
      But i am using Meganav and UberMenu, because it naturally synchronize with Ubermenu, NavPro doesnt.
      How can i align my menus to the right and leave the primary menu at center, see images

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • Jason
      By Jason+
      Hi.
       
      I am having an issue with meganav. If meganav is sticky on scroll when browsing in chrome, the menu jumps up and down from the top of the page.
      If you use the mouse scroll wheel or down arrow on the scroll bar the page will infinitely bounce the menu up and down with out actually moving down the page.
      the only way to get the page to move down is to resize the page or move the bar in the scroll bar down.
      I do realize that meganav does say sticky on scroll does cause some issues but is there any way round this?
      (This issue doesn't seem to affect firefox)
       Also pages slowly auto scroll up or down.
       
      Site in local development but you can see the same behavior on www.iheartpagelines.com
       
×