Jump to content
Toolshed

[Solved] Pagelines won't load / apparent javascript bug

Recommended Posts

Toolshed

Hello - I'm a registered Pagelines user. I tried to load my website today (toolshed.biz) in the DMS editor and received a message that the page was having trouble loading. I rarely make changes to my website so this was unexpected. I followed your support suggestions and checked for javascript errors using Chrome - when trying to load the page, it showed the following

jquery-migrate.min.js:2 JQMIGRATE: Migrate is installed, version 1.4.1
pl.editor.js?ver=16e8ee:740 Uncaught TypeError: Cannot read property 'lang' of undefined
    at Object.reloadConfig (pl.editor.js?ver=16e8ee:740)
    at Object.startUp (pl.editor.js?ver=16e8ee:72)
    at HTMLDocument.<anonymous> (pl.editor.js?ver=16e8ee:10)
    at i (jquery.js:2)
    at Object.fireWith [as resolveWith] (jquery.js:2)
    at Function.ready (jquery.js:2)
    at HTMLDocument.K (jquery.js:2)
303toolshed.biz/:1 Error in event handler for (unknown): TypeError: Cannot read property 'tab' of undefined
    at chrome-extension://kamiaabbnpncbobdiblhfogafnoefkae/contentscript.js:38:28

I deactivated all my plug-ins prior to doing this except for:

Pagelines Platform 5 v5.0.126

Pagelines updater v. 1.2.9

I'm not an expert coder or web developer, not really sure what this all means. Not sure what JQMIGRATE is (a plug-in? I don't see that in my plug-in list). Can you point me in the right direction?

Thanks,

Dick Huey

Share this post


Link to post
Share on other sites
Andrew

From what i can tell, I'm guessing you're having an actual PHP error and it is causing your page to output things incorrectly. 

 

First step is can you 'view source' and make sure all your HTML is there?

Share this post


Link to post
Share on other sites
Toolshed

Hi Andrew - thanks for the response and sorry I'm just seeing this.

I did check source - the page was built using PageLines, and I haven't changed anything since last year - and the editor was working fine up until my last update to the most recent version of Wordpress. If I share the source with you are you able to tell if anything is missing? It looks to me like everything is there.

The website is here - http://www.toolshed.biz - you can view the same source, the page seems to be working fine in a browser.

Web Inspector in Safari doesn't indicate any errors or warnings for the html for my homepage.

Share this post


Link to post
Share on other sites
Andrew

In that case, lets make sure you are using the most recent versions of everything. 
I'd have to see what was happening when you are logged in as this error is most often caused by a PHP error not something with JS. (PHP errors cause strange/error output or cutoffs which then create JS errors like the above)

Share this post


Link to post
Share on other sites
Toolshed

Hmm how can I let you log in as me? If you're an admin, do you just need my Wordpress username?

According to my dashboard, everything is updated.

And as mentioned previously, I created the page in Pagelines (which generated the html) and I also have not updated the page since it "stopped" working in the page editor. It was working fine up until recently, with no changes on my part.

Is it possible there's either a Pagelines or a PHP bug that is independent of my html?

Share this post


Link to post
Share on other sites
Andrew

Ya, have you checked for plugin conflicts? Also, checking your error logs at your host is recommended. 

Anything is possible, but the steps to figuring this out is to figure what sort of issue we have... JS error, php error, html error, etc.. 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • TJ Bawa
      By TJ Bawa+
      DMS Editor is not loading. I have tried using different browsers and also have cleared my browser cache, but still no luck. 
      Please find screenshotattached. 
      Thanks in advance! 

    • dbrowne02
      By dbrowne02+
      Hi, the DMS editor is not loading on landing page. It is working on all other pages. How do I fix this? the website is selborneproperties.com I have logged in and logged out, have disabled plugins. Thanks,
      David
    • jeomiland
      By jeomiland+
      Greetings
      Was on the phone with client yesterday reviewing the site and the server slowed way down. Did a couple updates that may not have taken. Now cannot get back into the DMS editor for http://cassclayton.com/dev/  I can see the site in chrome and firefox but the background image is no longer there. Can get into dashboard in chrome and firefox. Cannot get into DMS editor in chrome - get "Oops, There may be an issue loading." error no matter how many times I try.  My internet connection is not the fastest, but I can access other sites I've built in DMS - just not http://cassclayton.com/dev/
      My question is,
      1) is there a safe way to reinstall DMS that will not trash the work done on the site? 
      2) Is there a way to see if something in the database got corrupted and how to fix? Since I can't get into DMS editor, can't get to the Flush Cache page to try that.
      Just turned on
      define('WP_DEBUG', true);
      Help!
      Thanks
    • CjrMotley
      By CjrMotley+
      My DMS editor isn't working on my landing page, all other pages can be edited using the DMS editor. 
      Is there a fix for this???
    • cimbartlett
      By cimbartlett
      Hi, 
      I have been using the basic installation of DMS 2 for a month or so, and yesterday the DMS editor started displaying incorrectly.
       
      When I activate the editor, there is a gap on the left-hand side underneath the toolbar, so that the tools menu items appear shifted to the right, about half way across the screen, about level with the Pagelines.com "fern" logo button instead of under the close button. I can only see the tools if I use the Zoom in Chrome set at 75% or below.
       
      I bought the $99 package today, and reinstalled, but to no effect.
      I have Wordpress 4.2.2
       
      I had a number of other things not work properly on installation, including the demos (an item from Woocommerce fails to install, and there are a number of failures when installing the demo content using the wordpress installer).
       
      Hope you can help.
      Thanks
      Cim
×