Jump to content
balfred1345

CSS Not loading intermittently. Cache or Other Issue?

Recommended Posts

balfred1345

Hi,

I have a DMS2 site: piepho.com running the current version of WP and Sucuri Firewall with caching. 

The site fails to load CSS intermittently. I thought the problem was with the caching on Sucuri, but I clear the cache through the Sucuri API on every site update without fail. 

I need help getting to the bottom of this, as my client is losing patience with me, and I of course need to keep my clients happy. 

1) Can you tell me if there are other issues (not caching issues) that could be causing the site to look like the below image? Could there be a problem with the LESS compiler?

2) Sucuri has asked if DMS2 uses versioning on the CSS files. They explained versioning as follows:

With static files, it is best to use "versioning". This is done by adding a query string such as "?ver=123.1" and incrementing (such as ?ver=123.2) on each update.

3) I have both DMS Less Dev and DMS No Cache mode on. Could this be causing the site to not load CSS?

4) Is there an upgrade path from DMS2 to PL5 that does not involve me redoing the entire site, as the client will not be interested in paying for a new site? 

Looking forward to your response.

Thanks,

Bruce

1?ui=2&ik=221bd81492&attid=0.1&th=15ba51ab660c9a50&view=fimg&rm=15ba51ab660c9a50&sz=w1600-h1000&attbid=ANGjdJ_eHzUYccFwcX4QSZ_GyLHBHFzmyhcSdCTxAuog0Dfs6B97hJ7QGpPhuZGL3O3rX6FdVbXlpYvgkNB8IGzP7ey3vPzrQRb3R-Q7SCwgOyi090U3uVN9_MDTc7M&disp=emb&zw

Share this post


Link to post
Share on other sites
balfred1345

I see that the image didn't come through as pasted, so here is a screenshot of how the site looks when CSS doesn't load:

https://screencast.com/t/P9g0BtTTBVa

Thanks,

Bruce

Share this post


Link to post
Share on other sites
balfred1345

I checked the console for three browsers when the site doesn't load CSS to see what the errors were, in case that information is helpful. The below is all from loading the same page into the three different browsers:

Firefox Console:

The resource from “http://piepho.com/wp-content/uploads/pagelines/compiled-css-core.css?ver=1493155412” was blocked due to MIME type mismatch (X-Content-Type-Options: nosniff).

Safari Console:

[Warning] Unexpected CSS token: @baseLighterMore (compiled-css-core.css, line 1)
[Warning] Invalid CSS property declaration at: * (compiled-css-core.css, line 1)
[Warning] Invalid CSS property declaration at: * (compiled-css-core.css, line 1)
[Warning] Unexpected CSS token: : (compiled-css-core.css, line 1)
[Warning] Unexpected CSS token: : (compiled-css-core.css, line 1)
[Warning] Unexpected CSS token: : (compiled-css-core.css, line 1)
[Warning] Unexpected CSS token: : (compiled-css-core.css, line 1)
[Warning] Unexpected CSS token: : (compiled-css-core.css, line 1)

Chrome Console:

Failed to load resource: the server responded with a status of 404 (Not Found) compiled-css-core.css

Share this post


Link to post
Share on other sites
balfred1345

I've solved the MIME type mismatch issue, and understand the Unexpected CSS token warning is nothing to worry about. 

The remaining issue is the 404 that I'm getting after I've made a change on the site. 

Safari: Failed to load resource: the server responded with a status of 404 (Not Found)  http://piepho.com/wp-content/uploads/pagelines/compiled-css-core.css?ver=1493155412
Chrome:
GET http://piepho.com/wp-content/uploads/pagelines/compiled-css-core.css?ver=1493155412     (index):74 
  • Like 1

Share this post


Link to post
Share on other sites
cooldrive
On 4/26/2017 at 6:44 AM, balfred1345 said:

I've solved the MIME type mismatch issue, and understand the Unexpected CSS token warning is nothing to worry about. 

The remaining issue is the 404 that I'm getting after I've made a change on the site. 


Safari: Failed to load resource: the server responded with a status of 404 (Not Found)  http://scrapelink.com/content/wordpress-webinar-plugin/

Chrome:
GET http://piepho.com/wp-content/uploads/pagelines/compiled-css-core.css?ver=1493155412     (index):74 

Thanks, that really helped me fix my issues . It was tough becuase the site failed intermittently and it was completely random.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • jaithai
      By jaithai+
      Unable to attach an image that's already been uploaded.
      When attempting to upload one from scratch, it gives me the error seen in the screenshot. As you can see by the Chrome Inspector, I receive a 400 error.
       

    • stijnxo
      By stijnxo+
      Ik like to use the following Plug-in in my DMS Theme, but can' get it to work. My DMS Editor is not loading anymore if I paste this short code in a page, textbox or mediabox: [wpdatatable id=1]
      Plug-in: WPDataTables Plug-in 
      Shortcode:  [wpdatatable id=1]
      Website: http://gentleclinics.nl/prijslijst-heren/

      Anyone experience with this plug-in and DMS.
    • foxwatson
      By foxwatson+
      I recently downloaded the latest DMS2 update. Since the download, I lost front end ability to update. Any suggestions would be appreciated.  
    • Justin Taylor
      By Justin Taylor
      I originally purchased, I believe, a 3 site licence for DMS2. The new account interface does not reveal any of this information.
      How do I know how many licences I am entitled to? How do I reset one for a new website? All it says now is that I don't have any Pro licences?
    • HenryMote
      By HenryMote
      Hi guys,
       
      I have DMS and the maps isnt working. Here's the link to the site where you can see the error .http://plumb-now.co.uk/
       
      Thanks for your help!
       
×