Jump to content
Sign in to follow this  
Robert Thomas

TourGuide Module Insecure Images for HTTPS

Recommended Posts

Robert Thomas

I have deployed Let'sEncrypt via ServerPilot on my Digital Ocean droplet and I am showing that the following page is not secure. 

https://beautiful.fail/teaching/

This is a portfolio page of my teaching websites using TourGuide. When I go into View > Developer Tools > Security > MIxed Content (and reload to see the 9 errors) it returns 9 requests from the TourGuide module that it says are insecure: 

thumb-intro.jpg          
thumb-ad.jpg          
andrew-powers.jpg          
smartphone-iphone.svg          
move-up.svg          
window-flash.svg          
file-code-setting.svg          
modules-1.svg          
group-add-1.svg          

the Console screen below shows the following:

       

JQMIGRATE: Migrate is installed, version 1.4.1
(index):1 Mixed Content: The page at 'https://beautiful.fail/teaching/' was loaded over HTTPS, but requested an insecure image 'http://beautiful.fail/wp-content/plugins/pl-section-tourguide/thumb-intro.jpg'. This content should also be served over HTTPS.
(index):1 Mixed Content: The page at 'https://beautiful.fail/teaching/' was loaded over HTTPS, but requested an insecure image 'http://beautiful.fail/wp-content/plugins/pl-section-tourguide/thumb-ad.jpg'. This content should also be served over HTTPS.
(index):1 Mixed Content: The page at 'https://beautiful.fail/teaching/' was loaded over HTTPS, but requested an insecure image 'http://beautiful.fail/wp-content/plugins/pl-section-tourguide/images/andrew-powers.jpg'. This content should also be served over HTTPS.
(index):1 Mixed Content: The page at 'https://beautiful.fail/teaching/' was loaded over HTTPS, but requested an insecure image 'http://beautiful.fail/wp-content/plugins/pl-section-tourguide/images/smartphone-iphone.svg'. This content should also be served over HTTPS.
(index):1 Mixed Content: The page at 'https://beautiful.fail/teaching/' was loaded over HTTPS, but requested an insecure image 'http://beautiful.fail/wp-content/plugins/pl-section-tourguide/images/move-up.svg'. This content should also be served over HTTPS.
(index):1 Mixed Content: The page at 'https://beautiful.fail/teaching/' was loaded over HTTPS, but requested an insecure image 'http://beautiful.fail/wp-content/plugins/pl-section-tourguide/images/window-flash.svg'. This content should also be served over HTTPS.
(index):1 Mixed Content: The page at 'https://beautiful.fail/teaching/' was loaded over HTTPS, but requested an insecure image 'http://beautiful.fail/wp-content/plugins/pl-section-tourguide/images/file-code-setting.svg'. This content should also be served over HTTPS.
(index):1 Mixed Content: The page at 'https://beautiful.fail/teaching/' was loaded over HTTPS, but requested an insecure image 'http://beautiful.fail/wp-content/plugins/pl-section-tourguide/images/modules-1.svg'. This content should also be served over HTTPS.
(index):1 Mixed Content: The page at 'https://beautiful.fail/teaching/' was loaded over HTTPS, but requested an insecure image 'http://beautiful.fail/wp-content/plugins/pl-section-tourguide/images/group-add-1.svg'. This content should also be served over HTTPS.

Any thoughts on this? Thanks so much. - Rob

wow. something went wrong when I logged in to the forum. It is incorrectly showing me as a newbie ... 

Edited by Robert Thomas (see edit history)

Share this post


Link to post
Share on other sites
Andrew

hey Robert, 

You have a live link to this? You may have to change a value in the DB manually from a http prefix to https... if that's not the issue, we may have to reupload images, (or again change their url in the DB) and so on...

Share this post


Link to post
Share on other sites
Rob Thomas

Thx Andrew, the link was in the first post:

https://beautiful.fail/teaching/

I'd appreciate any help with this.

PS i reverted back to my original email address in my profile and it looks like it's normal again

Share this post


Link to post
Share on other sites
Andrew

@Rob Thomas my best advice for easy fixing of all mixed content issues is to first do this: 

  • Go into your PHPMyAdmin or other database tool
  • Search your option keys and other tables for 'http://' <- the non secure root
  • Replace all values with 'https://'

I suspect that you have some DB values stored incorrectly that simply need to be changed

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • Queue-it
      By Queue-it+
      Hi,
      Pagelines has great extension called "Tour guide", but on the mobile the sections don't break up in a user friendly way.  I attached an image with a mobile view, where the section is set to break with text-button - image instead of text-image-button. 
      https://www.pagelines.com/product/pl-section-tourguide/
      Is there an easy way to change that sequence?
       

×