Jump to content
sfmstudios

Javascript Error DMS + PL5

Recommended Posts

sfmstudios

I have a site (www.bodyandsoulcoaching.com) running DMS2 with PL5 on top of it and it recently has prevented me from using the front-end DMS editor unless I disable the PL5 plugin.  And yes, I did narrow it down to that...DMS editor loads fine when PL5 is disabled.  It's throwing the following Javascript error in the console:

Uncaught TypeError: Cannot read property 'lang' of undefined
    at Object.reloadConfig (pl.editor.js?ver=57d985:740)
    at Object.startUp (pl.editor.js?ver=57d985:72)
    at HTMLDocument.<anonymous> (pl.editor.js?ver=57d985:10)
    at i (jquery.js?ver=1.12.4:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
    at Function.ready (jquery.js?ver=1.12.4:2)
    at HTMLDocument.K (jquery.js?ver=1.12.4:2)
reloadConfig @ pl.editor.js?ver=57d985:740
startUp @ pl.editor.js?ver=57d985:72
(anonymous) @ pl.editor.js?ver=57d985:10
i @ jquery.js?ver=1.12.4:2
fireWith @ jquery.js?ver=1.12.4:2
ready @ jquery.js?ver=1.12.4:2
K @ jquery.js?ver=1.12.4:2
 

Any quick fix out there?  I eventually would like to move to PL5 exclusively, just not ready yet...

 

Screen Shot 2017-03-02 at 8.48.53 PM.png

Share this post


Link to post
Share on other sites
Andrew

Right, first things to check:

  1. are you using the absolute latest versions of PL5 and DMS
  2. is it possible you're having a conflict with another activated plugin?

Share this post


Link to post
Share on other sites
sfmstudios

Hi Andrew...

Yes:

  • WP 4.7.2
  • PL5 5.0.142
  • DMS 2.2.4

I deactivated all plugins and the site opened fine while still logged in, re-enabled one by one until all I was left with was the Pageliness PL5 (and extensions).  Activated PL5 and then the problem occurred.  I even toggled the disable/enable just to be sure.

Share this post


Link to post
Share on other sites
Andrew

Ok well, make sure to update to latest PL5 we are on 5.1.7... 

Do that and if there is still an issue we can dive deeper. 

There were some DMS / PL5 issues fixed on some later releases so im hopeful.

Share this post


Link to post
Share on other sites
sfmstudios

Hi Andrew...

My apologies - I didn't realize there was a later version, as it didn't prompt me to update in the Dashboard.  Manually updated and that seemed to have fixed it.  Thanks for your assistance!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×