Jump to content
Sign in to follow this  
andulka

Removing sidebar on highlight page

Recommended Posts

cmunns    16
cmunns

You can remove the black dot and use this CSS to achieve formatting that you want. ` #highlight .fcontent { margin-top:40px; } `

Share this post


Link to post
Share on other sites
andulka    0
andulka

Andrew, like I said earlier, it's a particularly public week for the band and we can't have the page looking a mess, so no, at the moment I can't add any of the problems as I'm working very hard to stop them from showing. :-) And adding one seems to escalate even more problems so I'm really just trying to leave it as it at the moment. Somehow things seem to get messed up after I published that one highlight page. It seems now whatever formatting is added to the actual text box on almost any page, will affect the sidebar, footer, whatever. I just noticed that in IE (perhaps all this is not related, but since it seems to have something to do with the highlight page I'll add it here) the custom font colour defined in css has all of a sudden stopped working on English (default) pages, which are shown in a slightly darker greyish font colour (not the default, lighter than that, about the same as the text in the sidebar) unless I manually change them. Which isn't very nice as the white text then won't show in the visual editor at all. The custom colour does work on the Finnish pages, but on the English language pages it won't change even if I update the pages and/or remove and add back the custom colour. I've checked about a million times and the pages are identical apart from the actual text, the posts usually don't even have any formatting added, unlike the pages. If I edit the text in the actual text area weird thing happen. In the case of the Home page (not the current default but the one that says 'Home') by changing the text colour white, the text in the sidebar turned white and bold as well, not on other pages, only on 'Home', and not the text in the Blog entries widget, which is defined in custom css. This happened in other browsers as well, not just IE. In Fan Photos, I noticed the entire text had turned red, the same colour the link on top is - including the text in the leave comments section. This again only in IE. As far as I can see, all these problems started after I published the one highlight page... The custom code in use is

body{
	background:#000 url("http://www.fluteofshame.com/wp-content/uploads/2010/12/1179032744-949-0.jpg");
	http://www.fluteofshame.com/bio/
	line-height:20px;
	font-size:14px}
	
	#nav ul, #nav .mnav{width:623px}
	#searchform {width:200px;}
	#s {width:170px;}
	
	#site #contentborder{background:none}
	
	#sidebar #bns-featured-category-3 .hentry{
	background:none;
	border-top:2px solid #222222;
	clear:both;
	overflow:hidden;
	padding:1px;
	padding-left:10px}
	
	.bns-featured-category strong a{font-weight:normal}
	
	.page-template-page-highlight-php #sidebar{display:none}
	
	.page-template-page-highlight-php #highlight{background:none}
	
	.page-template-page-highlight-php #maincontent{width:958px}
	
	#highlight .highlight-head, #highlight .highlight-subhead {
	display:none;
	}

I have deactivated all recent plugins but that doesn't seem to have any effect on any of this. Obviously a slightly different font colour in one browser isn't the end of the world, but it would be nice to have a uniform colour throughout the site...

Share this post


Link to post
Share on other sites
andulka    0
andulka

Sorry, the one line in the code that is a link is a c&p error, should read:

color:#fff;

:-)

Share this post


Link to post
Share on other sites
andulka    0
andulka

Hi, sorry for the late reply and yes, as I mentioned in the previous message, the

the http://www.fluteofshame.com/bio/
was just a c&p error and did not appear in the actual custom css, which still remains as given by you in another thread. :-) But going back to the original subject of sidebars, I would now like to remove the sidebar from a feature page as well. Earlier in this thread I got a code that removed the sidebar on a highlight page and would like to make sure I'm not messing it up if I use the same code modified, like this. Original for highlight page:
.page-template-page-highlight-php #sidebar{display:none}
	.page-template-page-highlight-php #highlight{background:none}
	.page-template-page-highlight-php #maincontent{width:958px}
To remove the sidebar etc. on a feature page: .page-template-page-feature-page-php #sidebar{display:none} .page-template-page-feature-pagephp #highlight{background:none} .page-template-page-feature-page-php #maincontent{width:958px}

Share this post


Link to post
Share on other sites
andulka    0
andulka

Right, managed to copy it wrong again but the latter code is the same as the first one, only with 'highlight' replaced by 'feature-page'.

Share this post


Link to post
Share on other sites
bryan-hadaway    3
bryan-hadaway

Well it's important to know whether you want to remove the sidebar from just one feature page or all feature pages. If just one let's get a link. Also, if you're using PlatformPro, when editing any page, scroll done bottom right there is a good list of options to hide sections on that page. Thanks, Bryan

Share this post


Link to post
Share on other sites
andulka    0
andulka

Just for the one at the moment Bryan, but I should think I wouldn't want it on any feature page if there were to be more than one. It's Station Pro I'm using. Sorry about the link, I seem to have omitted that as well, as again there isn't any public page as yet. It will look something like this, and like I said, it seems to work ok and removing the sidebar from all feature pages is ok too.

Share this post


Link to post
Share on other sites
bryan-hadaway    3
bryan-hadaway

Okay, I just recommend the on page options as I described, that might be best. So you can configure each page exactly as you want as you go along. Thanks, Bryan

Share this post


Link to post
Share on other sites
andulka    0
andulka

Bryan, I'm not using Platform Pro, I don't have such page options in Station Pro which is what I am using.

Share this post


Link to post
Share on other sites
Andrew    201
Andrew

Hey Jaana, Assuming you are having the same issue.. as when the thread started. Why can't you just hide the sidebars on the pages you want them hidden? I think this thread is getting long and to drawn out to read.. can we start a new one; that summarizes the existing issues? (sorry we haven't been able to resolve your issue yet)

Share this post


Link to post
Share on other sites
andulka    0
andulka

Andrew, I already ready started another thread about the IE problems, just basically wanted a confirmation that the code I'm using is correct and doesn't add to the problems. Reason why I couldn't remove the sidebars with the hide when empty option was that a box with the text 'sidebar selected but doesn't any widgets...' was still displayed, so had to use some code to get rid of them.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×