Jump to content
Simon

WordPress 4.7.1 Uploading SVG bug

Recommended Posts

Simon

WordPress 4.7.1 was released on 11th January.

It introduced a new bug that stops certain filetypes from being uploaded.

This bug unfortunately stops users from uploading SVGs with the Platform 5 builder.

In the meantime if you need to upload an SVG or have any other image upload issues then please try this plugin that bypasses the mime checks that were introduced.
https://wordpress.org/plugins/disable-real-mime-check/
 

Quote

With the upgrade to WordPress 4.7.1, some non-image files fail to upload on certain server setups. This will be fixed in 4.7.3, see the Trac ticket.

In the meantime, this plugin is a workaround that disables the recently introduced strict MIME check to restore the upload functionality.

Don't forget to remove the plugin once WordPress 4.7.3 is available!

Link to trac ticket: https://core.trac.wordpress.org/ticket/39550

EDIT: 4.7.2 has been released without the fix. Fix is now slated for 4.7.3

Edited by Simon
4.7.2 released without fix. (see edit history)

Share this post


Link to post
Share on other sites
j powers

Simon is that why I would be getting this message when trying to load paglines zip as a new theme 

 

Unpacking the package…

Installing the theme…

The package could not be installed. The theme is missing the style.css stylesheet.

Theme install failed.

Share this post


Link to post
Share on other sites
Andrew

@j powers are you installing the plugin as a theme? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • petere21
      By petere21+
      After changing protocol http to https I have lost all count information next to the icon in the Sharebar extension. All counts is set to zero. Is there any chance to give number of sharing take back? 
      thanks
    • stebac
      By stebac+
      Hello!

      Since i recently updated to WordPress 4.9.4 there have been some unusual behaviours with Platform 5 (version 5.1.8).

      I am unable to edit the colour pickers for the backgrounds (the boxes do not show up anymore) and when i activate a plugin from the extend menu it does not show up in my page editor tools.
      Is this a problem for everyone else?
      Thank you in advance for your time.
      Ste.
    • petere21
      By petere21+
      Is it possibble to remove header / footer on selected pages?
      I want to make some extra pages for app but I need  to remove header.
      Do you have any idea, how to do it?
      thnx
    • petere21
      By petere21+
      1. When I use the Navpro section in header with PL5 framework I loose social icons in mobile view (dtp and tablet are ok) Almost 50% of clients come from mobiles. Without this icons is menu unusable.
      2. Text of submenus is alligned center and there is no feature to allign it left.
      Do you have any ideas? thnx
    • gregory.guz
      By gregory.guz+
      Hi ,
      I just noticed that the color picker has stopped showing up on my PL5 site ( please see attached image ) 
      Any idea what could be causing the problem?
       
      Thanks 
      Greg

×