Jump to content
pmt@groevenbeek.nl

Error when installing for first time

Recommended Posts

pmt@groevenbeek.nl

Dear Pagelines,

I just installed wordpress on my brand new site and then the plugin for Pagelines platform. Immeditately I got an error.

Error 1: Database Error Platform 5 was unable to create table W2S8l11yU0_pl_data_maps

Error 2: Database Error Platform 5 was unable to create table W2S8l11yU0_pl_data_sections

There's nothin g at all on the site, no themes or anything.  What can go wrong already?

Tamar

Share this post


Link to post
Share on other sites
Simon

The database you setup does not have permissions to create new tables.

Share this post


Link to post
Share on other sites
pmt@groevenbeek.nl

Ok, thanks for quick reply. What do I do to give it permissions?

Share this post


Link to post
Share on other sites
Simon

When you created the database, you must have selected the user and user permissions, CREATE needs to be one of them.

Share this post


Link to post
Share on other sites
pmt@groevenbeek.nl

I didn't create a database, I just bought some webhosting with Wordpress; activated wordpress and downloaded the plugin. No user permissions.

Share this post


Link to post
Share on other sites
Simon
18 minutes ago, pmt@groevenbeek.nl said:

I didn't create a database, I just bought some webhosting with Wordpress; activated wordpress and downloaded the plugin. No user permissions.

You should contact your host and ask them how to add CREATE to mysql database permissions.

A lot of plugins require this, woocommerce for example.

Share this post


Link to post
Share on other sites
pmt@groevenbeek.nl

OK, thanks. Will look into it.

 

Share this post


Link to post
Share on other sites
pmt@groevenbeek.nl

Ok, checked. All user permissions are on. Deleted everything, started fresh. Still same error. Can anyone help?

Share this post


Link to post
Share on other sites
Simon
2 minutes ago, pmt@groevenbeek.nl said:

Ok, checked. All user permissions are on. Deleted everything, started fresh. Still same error. Can anyone help?

Checked what? have you a screenshot?

Share this post


Link to post
Share on other sites
pmt@groevenbeek.nl

I want to get on to be able to try the Pro account, but this error has taken up a good part of whole day. Hopefully this is not the start of more troubles to come.

 

Share this post


Link to post
Share on other sites
Simon
Just now, pmt@groevenbeek.nl said:

I want to get on to be able to try the Pro account, but this error has taken up a good part of whole day. Hopefully this is not the start of more troubles to come.

 

To install wordpress it needs to create its own tables, your host must be removing the the permission after install. None of this is normal.

Share this post


Link to post
Share on other sites
pmt@groevenbeek.nl

I see, but what do I do to fix this. I'm no SQL expert.

The host has a 'wordpress' install button, it does  everything automatically, including the databases, in which all permissions are on. Would it perhaps be better install it manually?

 

Share this post


Link to post
Share on other sites
Simon

Can you not see the database and alter permissions?

Share this post


Link to post
Share on other sites
pmt@groevenbeek.nl

I can see the database and alter but everything is set to true. I have permissions to CREATE and DROP

Share this post


Link to post
Share on other sites
Simon

Are the tables actually created? Where are you seeing the error? Do you have a live url?

Share this post


Link to post
Share on other sites
pmt@groevenbeek.nl

I'm trying to upload screen shots but don't see where I can do this. I'm sorry, new today

 

Share this post


Link to post
Share on other sites
pmt@groevenbeek.nl

Here is the site: http://tto-chronicles.nl/wp-admin

***

I've checked the Database, as you said the tables are empty. Can I add them manually? And if so, what's the Query?

I don't think this should be happening, but have no idea how to do it otherwise.

Edited by Simon
dont post passwords. (see edit history)

Share this post


Link to post
Share on other sites
Simon

OK, logged into your site, the warning that shows in the admin error is just a warning.

The reason its showing is becase you dont have permissions to show the tables, we use that to see if it was successfull.

Im changing the code anyway

Share this post


Link to post
Share on other sites
pmt@groevenbeek.nl

So, it's ok. I can go ahead and install PRO?

But the databases ARE empty. I checked. Is this correct?

 

Share this post


Link to post
Share on other sites
Simon
4 minutes ago, pmt@groevenbeek.nl said:

So, it's ok. I can go ahead and install PRO?

But the databases ARE empty. I checked. Is this correct?

 

Yes, data will be stored there when you edit the site.

Share this post


Link to post
Share on other sites
pmt@groevenbeek.nl

Ok. Great. Thank you for your time!

Share this post


Link to post
Share on other sites
Simon

The warnings are removed in a later release.

Share this post


Link to post
Share on other sites
pmt@groevenbeek.nl

Hello anyone,

I'm having enormous problems. I think I've deleted and started a fresh about 15 times now. This is waht happens (even with the yesterday's update).

1. Still having database errors.

2. Spinning Cog never loading Extensions

3. Not being able to edit any pages with the page editor.

All settings are correct. There are no plugins to upset any scripts. It's clean, there's absolutely nothing on there, also have the latest version of everything. Installation of the basics has cost me 2.5 days and still nothing.

Please  help a.s.a.p. I am starting to think Pagelines was a big mistake!

Share this post


Link to post
Share on other sites
Simon

Feel free to open a ticket and supply login info.

The database 'warnings' are nothing to worry about and they are only in the admin area. Like I said they are nothing to be alarmed about and in fact the warnings are already removed in the next build.

The spinning cog will be a javascript error.

Share this post


Link to post
Share on other sites
pmt@groevenbeek.nl

Ok, will do that. 

Where does the javascript error come from? There's nothing on the site.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×