Jump to content
Queue-it

[Solved] search not working

Recommended Posts

Queue-it

HI,

Search function doesn't seem to work. 

When ever searching for something it redirect to the home page and add the search string to the url.

For example searching for "cases" it would display https://queue-it.com/?s=cases

Do you know how to solve that? 

Share this post


Link to post
Share on other sites
Simon

Platform 5 does not do anything to the search query and your theme should display the search template.

Have you tried deactivating plugins to see which is hijacking the query?

Share this post


Link to post
Share on other sites
Queue-it

Actually, now the search disappeared after updating the Pagelines Platform 5. 

Will look more into the plugins then. 

Share this post


Link to post
Share on other sites
Simon

The search button was accidentally removed, 5.1.1 reverts that patch.

Share this post


Link to post
Share on other sites
Simon

The update has nothing at all to do with your read more links, which appear to be loops plugin based? anyway i clicked a few they all work.

Share this post


Link to post
Share on other sites
Queue-it

That's weird clearing cache, hasn't helped to see that. Will try to solve it and let you know about the solution then.

Share this post


Link to post
Share on other sites
Simon

do you get a javascript error?

Share this post


Link to post
Share on other sites
Queue-it

This is what I see from my side.

Screen Shot 2016-11-28 at 22.47.35.png

Share this post


Link to post
Share on other sites
Queue-it

We've solved it, that was a cloud flare setup, that was interfering with Pagelines.

Share this post


Link to post
Share on other sites
laldan

I'm getting the same issue. The search redirects to someother age with the string attached to the url at  the end like this "?s=test&submit=Search+›" 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • mtaus
      By mtaus+
      How can I remove the Search function from NavPro?
    • John Olsson
      By John Olsson+
      Hello, i'm working on a webshop, and got this code to really boost the search within WP. But when adding this code to functions.php the front end media library search flipped totally, and not working at all, any ideas what's the problem?
      function atom_search_where($where){ global $wpdb; if (is_search()) $where .= "OR (t.name LIKE '%".get_search_query()."%' AND {$wpdb->posts}.post_status = 'publish')"; return $where; } function atom_search_join($join){ global $wpdb; if (is_search()) $join .= "LEFT JOIN {$wpdb->term_relationships} tr ON {$wpdb->posts}.ID = tr.object_id INNER JOIN {$wpdb->term_taxonomy} tt ON tt.term_taxonomy_id=tr.term_taxonomy_id INNER JOIN {$wpdb->terms} t ON t.term_id = tt.term_id"; return $join; } function atom_search_groupby($groupby){ global $wpdb; // we need to group on post ID $groupby_id = "{$wpdb->posts}.ID"; if(!is_search() || strpos($groupby, $groupby_id) !== false) return $groupby; // groupby was empty, use ours if(!strlen(trim($groupby))) return $groupby_id; // wasn't empty, append ours return $groupby.", ".$groupby_id; } add_filter('posts_where','atom_search_where'); add_filter('posts_join', 'atom_search_join'); add_filter('posts_groupby', 'atom_search_groupby');  
    • MissT
      By MissT+
      Would be great to have the ability to include a search option within menus and within Splashup - is this possible?
    • balfred1345
      By balfred1345
      null When I tested Search using the search field in Navi, it throws the error as shown in pastebin: http://pastebin.com/DJ079bmy
      Is there a fix for this? If there is no fix, can you please tell me how to disable search in Navi?
      Thanks,
      Bruce
    • MissT
      By MissT+
      Hi there,
      Just wondering if there is a reason why there is no search option within Multimenu as there is with Navi - would be good if it did have it and it worked in a similar way and you could switch it off when you need to.
      Many thanks.
×