Jump to content

Archived

This topic is now archived and is closed to further replies.

BlueSkyCreative

SEO Image Alt tags not showing for seo

Recommended Posts

BlueSkyCreative

Hi there,

I have a dev site I am working on and my seo plugin is not being able to see the image alt tags

to test this I have an image on the top section in an image section here http://213.5.177.31/~northsho/keys2drive/

but in the source code the image tag is not registering? I have also added the image via the media library, added the alt and it doesn't work that way either

At the moment I am just trying with the image section but hope that the binding alt tags for any of the images in sections would work, I have not tried yet, but want to see why the main image isn't first

Thanks In advance :) 

 

Paul

Screen Shot 2016-09-16 at 08.13.19.png

Screen Shot 2016-09-16 at 08.13.51.png

Screen Shot 2016-09-16 at 08.14.14.png

Screen Shot 2016-09-16 at 08.14.44.png

Screen Shot 2016-09-16 at 08.21.50.png

Share this post


Link to post
Share on other sites
BlueSkyCreative

Hi Simon

Not sure whats going on there then? as here are two page sources 1 Safari and 1 Chrome and they both don't show the alt tags?

Even checked on a different machine...?

Any ideas why my browsers are not showing the alt tags? 

 

 

 

Screen Shot 2016-09-19 at 16.36.35.png

Screen Shot 2016-09-19 at 16.34.53.png

Share this post


Link to post
Share on other sites
Simon

you are looking at the source HTML not the rendered HTML, click the elements tab and find it there.

Share this post


Link to post
Share on other sites
BlueSkyCreative

Cheers Simon, Ok 

I see that now....mmmmm I will get onto seopressor connect then and see what they say as their plugin is not seeing the alt tag for the image

I will post back when I get to the bottom of it :) Many thanks

Paul

 

Share this post


Link to post
Share on other sites

  • Similar Content

    • flourishdesignstudio
      By flourishdesignstudio+
      Hello,
      We are working on a site and the customers are complaining that the site loads too slowly. They contacted their host who mentioned that the Java Script is all loading at the beginning. Is it possible to delay the load of the less important Java Script until after the initial load to speed up the site? The goal is to load the page faster by minimizing the initial javascript calls.
      Are there any preferred plugins that you would recommend or does this end up causing excessive problems with plugins, etc.?
      Thanks for the help!
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      It seems like the H1 tag in the Pagelines 5 framework is missing the entry-title tag. Google Search Console complains about that and it seems like it needs to be fixed in the theme. Based on another thread, this looks like a known issue but I haven't seen any updates from the framework team.
      Any indication of what the status on this issue is?
      The site in question that I have that issue with is michaelkummer.com.
      Thanks
      Michael
    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. I just past my PL5 website to BING analyser, and I was very surprise when it told me I had five <H1> ! ? What ? how it's possible ?? 
      So I have checked the code, and obviously, some PL plugin (like Elements), create some <h1> balises for their Header.... Great ! 
      So I have try to simply not use this Element's Header, leting them blanck. But <H1> balise is still there ! Empty but sill there ! ( <h1 class="elements-header" data-bind="plshortcode: header"></h1>).
      I have took Element as exemple, but it's the same for other PL plugins. Even if you let a part blank, PL plugin will create an empty balise ! :-(
      I'm not developper, and don't know PHP. But I guess it's possible to create a fonction, witch would say . 
      "if one balise is empty => then don't write it."
      What guy's do you think about that ?
       
       
      There is a link to my website : http://www.wedding-photography-minneapolis.com/
    • Queue-it
      By Queue-it+
      Hi,
      We're using Yoast SEO plugin and it can not crawl the content that is in a Pagelines text container, only the Paglines framework content. 
      I can see that it is a problem with SEO plugins and external site builders to read the content. So is there a Pagelines SEO plugin that would solve that? 
      I know that it does not effect stats on google, but it is not possible to see the full picture of SEO status. 

    • janpeeters
      By janpeeters
      Hi,
      I'm trying to figure out if it's Pagelines 5 that causes the following problem in the Google search index. When you search for: https://www.google.nl/search?q=site:https://energiek-leren.nl Google Search Index shows a ghost page with the URL: https://energiek-leren.nl/page/2/ 
      I didn't create that page in Wordpress nor is it visible in my Yoast SEO sitemap (https://energiek-leren.nl/page-sitemap.xml)
      When you change the extension 2 of that ghost page URL to 3, 4, 5 or whatever it still loads the front page. Anyone knows what causes this? I'd love to not have these kind of pages show up in index.
      Thank, Jan
       
       
×