Jump to content

Archived

This topic is now archived and is closed to further replies.

SaschaM

Headline Structure Errors with PL5 Plugin Elements and Impulse

Recommended Posts

SaschaM

From a SEO perspective the PL5 Plugins: Elements and Impulse are producing site struture problems with the h1-hX tags and i dont make a designer very happy, cause the problems can not resolved easy way.

reasons:

1. Impulse

If you add item slide headers its rendered as graphic text - not readable by searchengines. result is an empty h2. second impulse is most times one of first element on the site. the h2 tag to be first is wrong. it must be h1.

in order to fix it i have to place an h1 text elements before impulse - which destroys my beautifull layout.

2. Elements

For Layout reason the PL5 plugin generates h1 and a h3 headline in order to style the layout (as you know headline elements should not be used for styling). This is also not correct, cause from seo perspective only one h1 ist recommended on page. With placing callouts and heros in the content you have an additional h1, which indicates wrong content to searchengines. h1 is on a correct SEO website one of the first elements.

in my case i use different callouts and heros sometimes 2 or more on a side and than i have to all this h1-h3 structure problems

Questions:

For Elements i build now a SPAN solution with shortcodes to replace elements callout, but this is also not perfect. is there a way to modify the headlines 1) by a functions add_filter 2). modify the plugin source code in a child theme?

would be nice if we can have a dicussion on it...or somebody has a solution for this problem....i am trying now for some days finding a solution maybe i am blind but not stupid.

 

 

 


Sascha Muhlen

South Spain

Share this post


Link to post
Share on other sites
Simon

Search engines render javascript perfectly well and have done for years.

Where are you getting information thats its bad for seo?

Share this post


Link to post
Share on other sites
SaschaM

this is not the point simon render the javascript :-) and not the problem, i have more than 10 years experience in seo and webdesign i know what i do.

here you have original video of Matt Cutts regarding h1 - hx issues. your plugins are placing various headlines to the source code...(Elements) with a h1 and h3 tag. the following up is

h1

h2

h3

etc.

excact in this row!!!!!!!!!

AND NOT like your pugins do - this is a SEO no go - absolut!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

h2

h1

h1

h3

h2

h1

h3

pp.

 

 

 

 

 

 

 

and if you see source code, in impulse the h2 headlines are empty. and in this case its not rendered correctly or what ever cause there are no entries.


Sascha Muhlen

South Spain

Share this post


Link to post
Share on other sites
Simon

reordering some headers isnt a massive issue.

what does this mean?

Quote

If you add item slide headers its rendered as graphic text - not readable by searchengines. result is an empty h2.

 

Share this post


Link to post
Share on other sites
SaschaM

this means the data bind is empty in impulse plugin (with other plugins you have text in the data bind) - so where is here headline and subheadline?

<div class="cell-text pl-trigger" >
  <h2 data-bind="pltext: text"></h2>
  <div class="subhead sub-title" data-bind="pltext: subtitle"></div>
 

</div>

 


Sascha Muhlen

South Spain

Share this post


Link to post
Share on other sites
Simon

When you add text in the settings it gets rendered into the page with the data bind.

Screen Shot 2016-09-12 at 18.05.30.png

Share this post


Link to post
Share on other sites
SaschaM

make me laugh it does not simon include the text cause i have text. i posted original source code to you.

 

this one is also wrong follow up of headlines in PL5 Elements plugin: (also orginal from your site not modified)

<h1 class="elements-header" data-bind="plshortcode: header">Probleme? Kein Grund den Kopf in den Sand zu stecken!</h1>

<h3 class="elements-subheader" data-bind="plshortcode: subheader"><div>Wir finden diskrete und effektive Lösungen.<br></div></h3>

 

as you see here the data bind is working as it does in impulse not.

 

 


Sascha Muhlen

South Spain

Share this post


Link to post
Share on other sites
Simon

Do you have a url example of it not working with impulse?

Share this post


Link to post
Share on other sites
Simon

Sorry Im not sure I understand fully? Whats suspicious? The header and subheader in impulse? Looks fine here...

Share this post


Link to post
Share on other sites
SaschaM

yes but text is not included in the source code....


Sascha Muhlen

South Spain

Share this post


Link to post
Share on other sites
Simon

Search engines do not read the source code, they havnt for years. They render the page as you see it, even the css. Thats how they check for display none and hidden content areas. You cant do all that stuff now as they fully render the page

Share this post


Link to post
Share on other sites
SaschaM

we now having trash talk i stop here cause this are no answers on my questions.


Sascha Muhlen

South Spain

Share this post


Link to post
Share on other sites

  • Similar Content

    • elementalkites
      By elementalkites+
      Good evening. I am attempting to use the Impulse section on a page I am working on (https://dev.elementalkites.com). The tool seems to have the ability to overlay a logo on top of the slider images but in my case it isn't working, even though I have added the logo file and given it a height to display at. I have attached a screenshot for reference. Any help would be appreciated.
       
       
    • tomtwigg
      By tomtwigg+
      There are some Impulse qualities (title, subtitle, alignment, overlay opacity) that I would like to modify, but when I view source I see that unlike other feature sliders that I've used with PageLines, Impulse seemed to be completely executed via script. Usually I would identify the div class or ID and change via LESS/CSS, but I've not a clue as to how to do it with Impulse. Any help is greatly appreciated.
      -Tom
    • burkemedia
      By burkemedia+
      Oddly, this is only happening on ONE website/WordPress installation. I've tried uninstalling and reinstalling Impluse as well as Pagelines 5, I've tried getting rid of my custom CSS/LESS with the LESS extension ... still not working.
       
      Basically, when I try to use Impulse it looks and functions wonderfully... UNTIL I refresh the page or view it logged out in another window... then it only shows a navigation menu.
      Screenshot below.
        

      Any idea as to what's wrong?
    • Jared Smith
      By Jared Smith+
      I'm using the Impulse section for a screen wide image. I'm seeing a funny thing though, whenever I turn off the page editor, all the impulse section pictures disappear.  It has been saved.  Any ideas.  I can send you login links if need be.
      With Editor ON (note, no save button)
      you can see the waterfall image
       
      When I turn editor off, it goes away
       
      Any suggestions?


    • StuLeeUK
      By StuLeeUK+
      Good morning,
      I have set up my homepage using the Elements sections, a Masthead at the top and then a selection of Heroes lower down.
      I only just realised that the Heroes set a H1, as does the Masthead.
      Is there an easy way I can change the Heroes to an H2/H3 etc so as to improve the structure of my headers, whilst keeping the Masthead as H1?
      I really don't know much at all about CSS, which is why I use Pagelines because it's just so easy to create good looking pages without too much confusion.
       
      page for reference is https://www.avangocouriers.co.uk
      Thanks,
      Stu
×