Jump to content

Archived

This topic is now archived and is closed to further replies.

Houston Haynes

Back-top object - only active when mouse-over footer area

Recommended Posts

Houston Haynes

OK - folks - back with another nit... The "back to top" link works - BUT - it's only active (i.e. clickable with the associated action following) when the mouse-over hovers over the footer area of the page. I did a quick change of the z-depth (to -1) and nothing made a difference. Any thoughts on how to make the *entire* back-to-top icon hover-able/actionable? Thanks!

 

Screen Shot 2016-09-01 at 8.54.11 AM (2).png

Share this post


Link to post
Share on other sites
Aires

Can we have a link to the site please.


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
Houston Haynes
On 9/2/2016 at 6:23 PM, Aires said:

Can we have a link to the site please.

Dude - total side note - mad props for I[heart]Pagelines! The subscription was worth it to me based solely on the PL5 tips alone. Given the amount of time that I've put into doing a (relatively tame) portfolio site I can only imagine the amount of lift required to build out that body of work. 

:bow:

Share this post


Link to post
Share on other sites
Aires

Thanks for the compliment @Houston Haynes,

After looking at your site and comparing it with the demo it seems as if something is overriding the css needed to get the back-to-top to function properly.

This CSS will get things working but I would try to find out what is overriding the default css. Could be a plugin or something.

.back-top {
  position: fixed!important;
  overflow: hidden!important;
  z-index: 10!important;
  
  }

 


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
Houston Haynes
1 hour ago, Aires said:

Thanks for the compliment @Houston Haynes,

After looking at your site and comparing it with the demo it seems as if something is overriding the css needed to get the back-to-top to function properly.

This CSS will get things working but I would try to find out what is overriding the default css. Could be a plugin or something.


.back-top {
  position: fixed!important;
  overflow: hidden!important;
  z-index: 10!important;
  
  }

 

Thanks for this - interesting - perhaps I mis-read how z-index functions. I thought setting it to -1 would do the trick. I certainly don't mind dropping an override in the style.css of my child site, but I think it would be interesting to understand where it's processed in the stack. I'm using the Material Pagelines theme, so I'll peruse the usual suspects (starting with following the CSS from the inspector).

Share this post


Link to post
Share on other sites
Houston Haynes

Bingo - bongo! :jig:

So, I decided to *just* leave the z-index setting - as the position override pushed the icon to the far right corner of the page. Now the link is "hot" for the entire surface area of the button/icon/control - whatever you want to call it - as desired. This means a simple tap on a tablet works without the user having to do multiple pokes/touches to get it to work (and it wasn't a picnic when using a mouse, either)

Some of my pages will be quite long (if I opt to stay with one-page-per-scenario) so I *may* look into ways to get it to appear on scrolled pages that are not *completely* at the bottom (showing the footer, essentially). I'll be looking into it *after* all of the fish-food is posted to the site. Any ideas on making a floating back-to-top would be greatly appreciated.

Share this post


Link to post
Share on other sites

  • Similar Content

    • Paul
      By Paul+
      I was surprised to see I had no menu today - out of the blue - its actually moved to the bottom of the page!  After hours of fiddling and disabling every single plugin, leaving just plagelines the issue is still present.  See video for a basic text box - I moved it into the head and it jumps to the bottom and shows just above the footer but below the main content.  I have a temp fix by placing the menu into the first row on the main content but it does mean other than my home page, all other pages have no menu.  A quick fix is very urgent for this bug.
      https://thelaptopfixers.com
       
       
    • Houston Haynes
      By Houston Haynes+
      Hey folks - I'm trying to get right of some 'dead space' at the bottom of the page in the Material Theme. (see attached) Those two gray lines have an "Edit" button in between them when the browser has a login cookie for the site. Here I created a screenshot from a browser session that doesn't have context for my main login, so you can see that the "Edit" indicator is gone, but the bars and the space it occupies still remains. Can someone help me isolate this so I can make it *completely* disappear? Thanks.

    • romanondrasek
      By romanondrasek+
      hi all, I have some trouble using PL5 on my site. 
      I used plugins for event calendar (event on) and plugin (timetable responsive scheduler for WP) for schedule (classes) in the gym.
      The problem is, that post from this 2 plugins are shown without menu in header and footer. (I setup header and footer) in the page editor for all type of page. 
      When I create a lesson, it creates posts with slug (I have a slug "lekce" & event for events).
      I try to edit the post with PL editor, but editor is not opening on the post.

      Do you have some idea where should be some problem? Thanx so much.
      here are links for the sites :
      site with schedule :
      http://www.myfit.cz/rozvrh/
      site of one of the class (pilates)
      http://www.myfit.cz/lekce/pilates/
      site with calendar :
      http://www.myfit.cz/kalendar/
      7 side with one event from the calendar :
      http://www.myfit.cz/event/pilates-instruktor-akreditovana-licence/?ri=1
      when I have my site on DMS2 it was working :-(
       
       
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      I have been unsuccessfully trying to get my 3-column widgetized footer aligned centered. The widget section itself is aligned left because the alignment appears to be controller the widget's content only. The container that contains the widget section is aligned centered. I have chosen a 3 column layout and I added 3 widgets, assuming they would be aligned centered.
      Any idea of what I may be doing wrong?
      The page is question is: http://www.michaelkummer.com
      Thanks
      Michael
    • carl
      By carl+
      How do I remove the leaf html5, css3 logos from the footer? Sorry if this have been covered a thousand times, but no clear cut solution available for my version of DMS2. Do I need to go pro to remove? Cheers!
×