Jump to content

Illegal string offset error in updater

Recommended Posts


This site has had no changes other than standard updates and never had this error until now: Wordfence Live Activity: Warning: Illegal string offset 'pagelines-updater' in /home/hoffman/public_html/wp-content/plugins/pagelines-updater/libs/product-updates.php on line 211 Warning: Illegal string offset 'version' in /home

I've enabled debug in DMS but not sure where to grab that. Haven't yet, but can, enable debug in wpconfig if required.

I'm running WP 4.6, DMS Version: 2.2.4 and Updater  Version 1.2.9.  I could just disable that plugin. But since I've never seen this before I thought it might be a known issue we could fix. I imagine there won't be many more updates, if any, so should I simply disable it?

Here's the rest of the site info gleaned via BackupBuddy:

[OK]     BackupBuddy Version   =
[OK]     WordPress Version   =   4.6
[OK]     MySQL Version   =   5.5.50
[OK]     AddHandler in .htaccess   =   none, n/a
[OK]     PHP Version   =   5.6.23
[OK]     PHP max_execution_time (server-reported)   =   30
[OK]     Tested PHP Max Execution Time   =   30 secs  
[OK]     BackupBuddy PHP Max Execution Time   =   30 secs
[OK]     Reported PHP Memory Limit   =   512M (local) / 512M (master)
[OK]     Tested PHP Memory Limit   =   510 MB  
[OK]     PHP Error Logging (log_errors)   =   enabled [Test]
[OK]     PHP Error Log File (error_log)   =   error_log
[OK]     PHP Display Errors to Screen (display_errors)   =   disabled
[OK]     Zip Methods   =   exec, ziparchive, pclzip  
[OK]     Database Dump Methods   =   php, commandline
[OK]     Site Size   =   Unknown  
[OK]     Site Size (Default Exclusions applied)   =   Unknown  
[OK]     Site number of files   =   Unknown  
[OK]     Site number of files (Default Exclusions applied)   =   Unknown  
[OK]     Database Size   =   31.13 MB  
[OK]     Database Size (Default Exclusions applied)   =   15.15 MB  
[OK]     Average Write Speed   =   2.09 MB/sec
[OK]     Guesstimate of max ZIP size   =   62.8 MB
[OK]     Http Loopbacks   =   enabled Hover for details
[OK]     wp-cron.php Loopbacks   =   enabled Hover for details
[OK]     Loopback Domain & IP   =   hoffmangraphics.com =>
[OK]     WordPress Cron   =   enabled
[OK]     WordPress Alternate Cron   =   disabled (default)
[OK]     Disabled PHP Functions   =   (none)
[OK]     PHP function: mysql_connect()   =   enabled
[OK]     PHP Register Globals   =   disabled
[OK]     PHP Magic Quotes GPC   =   disabled
[OK]     PHP Magic Quotes Runtime   =   disabled
[OK]     PHP Safe Mode   =   disabled
[OK]     PHP API   =   apache2handler
[OK]     PHP Architecture   =   64-bit
[OK]     Http Server Software   =   Apache
[OK]     Server Load Average   =   0.43, 0.49, 0.55
[OK]     PHP SSH2, SFTP Support   =   no, no
[OK]     WordPress ABSPATH   =   /home/hoffman/public_html/
[OK]     Operating System   =   Linux (Linux advanced1024.inmotionhosting.com 2.6.32-573.22.1.el6.x86_64 #1 SMP Wed Mar 23 03:35:39 UTC 2016 x86_64)
[OK]     Active WordPress Plugins   =   gravityforms/gravityforms.php, accordions/accordions.php, advanced-post-types-order/advanced-post-types-order.php, akismet/akismet.php, backupbuddy/backupbuddy.php, better-delete-revision/better-delete-revision.php, broken-link-checker/broken-link-checker.php, cleanup-images/cui.php, content-copyright/content-copyright.php, dms-dev-tools/dms-dev-tools.php, dms-plugin-pro/dms-plugin-pro.php, easy-theme-and-plugin-upgrades/init.php, enhanced-recent-posts/enhanced-recent-posts.php, google-analyticator/google-analyticator.php, gravityformsmailchimp/mailchimp.php, iwp-client/init.php, jetpack/jetpack.php, latest-custom-post-type-updates/index.php, manual-control/manual-control.php, nimble-portfolio-premium/nimble-portfolio.php, pagelines-customize/pagelines-customize.php, pagelines-googlefonts/pagelines-googlefonts.php, pagelines-postpins/pagelines-postpins.php, pagelines-updater/pagelines-updater.php, post-type-archive-links/post-type-archive-links.php, rename-wp-login/rename-wp-login.php, shoutout/shoutout.php, testimonials-by-woothemes/woothemes-testimonials.php, woosidebars/woosidebars.php, wordfence/wordfence.php, wp-help/wp-help.php
[OK]     PHP Process User (UID:GID)   =   Unknown (Unknown:Unknown)


Edited by sheilahoff (see edit history)

Sheila Hoffman | Hoffman Graphics | Seattle

Share this post

Link to post
Share on other sites

Thats only a php warning and can be ignored, if you have wp_debug off you shouldnt even see it.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now