Jump to content

Archived

This topic is now archived and is closed to further replies.

PierreFF

Issue with NavPro on Mobile on Platform 5

Recommended Posts

PierreFF

Hello, 

I have an issue with NavPro on mobile when the link of the menue is on the same page. 

Here is my website: http://foundersofthefuture.co

The isssue comes from the fact that in my menue most of the items send somewhere else on the same page using anchor link (eg. #container_u788888). 

This works well on desktop but on mobile, nothing happens when clicking on the link. One of the link of the menue of the homepage "France" sends to another page of the website and this one works well even on mobile. 

I am using the Pagelines framework theme and also used a wordpress plugin (jQuery Smooth Scroll) for smooth scrolling . 

Thanks in advance for your help and let me know if I need to provide more information. 

Best,

Pierre

Share this post


Link to post
Share on other sites
Simon

Hi there, theres something very odd going on there, could be a clash with javascript somewhere.

You have at least 2 'scroll to' plugins activated for a start, are you using both?

Try disbling plugins back to a minimum to figure out whats causing the issues.

Share this post


Link to post
Share on other sites
PierreFF

Hi Simon, 

I have tried with disabling all the plugins and I still have a problem. 

The only thing that change when I deactivate the plugin "jQuery Smooth Scroll" is that on mobile when I click on a menu item, I can see that this is loading a new link (eg http://foundersofthefuture.co/#container_u6bb2ca6) but nothing happens. 

I have also tried to set up Navpro on another site I have http://ffactor.me and I have the same problem.  (that should bring to the same page with the menu item "Contact Us") 

Anything else I could do?

Or is this something to fix on the Navpro section?

Thanks for your help. 

Share this post


Link to post
Share on other sites
Simon

I think the issue is here, when on mobile, the mobile overlay is full screen so your container that are linking to isnt actually on the page, if you see what i mean.

I'll ask ray if there is any way around this

 

Share this post


Link to post
Share on other sites
Simon

Fixed in an update.

Share this post


Link to post
Share on other sites
PierreFF

Thanks a lot Simon. 

I have updated and I have noticed that it works now. 

However, it doesn't work when my wordpress plugin "jQuery Smooth Scroll" is active. (it works well when it's deactivated). 

I have tried another plugin "Easy Smooth Scroll Links" and the result is the same. 

So,

would there be a way to make sure that it works with those plugins?

Or, 

what could be another way for me to add Smooth Scrolling on my website?

Share this post


Link to post
Share on other sites
PierreFF

Hi @Simon

Just making sure you had a chance to see this. 

I tried several way to add smooth scrolling other than plugin, but no luck on my side

On 8/9/2016 at 0:33 PM, PierreFF said:

Thanks a lot Simon. 

I have updated and I have noticed that it works now. 

However, it doesn't work when my wordpress plugin "jQuery Smooth Scroll" is active. (it works well when it's deactivated). 

I have tried another plugin "Easy Smooth Scroll Links" and the result is the same. 

So,

would there be a way to make sure that it works with those plugins?

Or, 

what could be another way for me to add Smooth Scrolling on my website?

 

Share this post


Link to post
Share on other sites
Simon

I cant see how its ever going to work, the mobile menu uses the whole width of your mobile screen so the element isnt there to scroll to.

 

Share this post


Link to post
Share on other sites

  • Similar Content

    • mtaus
      By mtaus+
      How can I remove the Search function from NavPro?
    • petere21
      By petere21
      1. When I use the Navpro section in header with PL5 framework I loose social icons in mobile view (dtp and tablet are ok) Almost 50% of clients come from mobiles. Without this icons is menu unusable.
      2. Text of submenus is alligned center and there is no feature to allign it left.
      Do you have any ideas? thnx
    • Grant Turck
      By Grant Turck+
      The Nav Pro section on our site venicepride [dot] org keeps breaking. Can someone help us out with why it is breaking or how to fix. Willing to pay. 


    • Grant Turck
      By Grant Turck+
      Navbar Broken on All Devices When Not Logged Into Wordpress. See screenshots attached from mobile. What is causing this issue and how do I fix? Site is venicepride [dot] org.


    • hibbsy78
      By hibbsy78+
      Updates to NavPro appear to have knocked out the alignment of the burger menu on mobile view (iPhone).
      https://www.hibbslupustrust.org/

      Version 5.0.9  

×