Jump to content

Archived

This topic is now archived and is closed to further replies.

claudedagenais

Saving changes in Pagelines Setting

Recommended Posts

claudedagenais

OK, funny story... 

I can't save any changes made in the Pagelines setting page on a website we are working on. I said it is funny, because on our MAMP server locally it works perfectly, but on our distant server instead of saving I'm getting a 404 with a URL that looks like .../wp-admin/admin-post.php

I've tried deactivating everything that is not Pagelines and I've tried different browsers and I got the same results. So it is not a plugin or cache thing.

I know it is the same server that had an old PHP but now it is running 7.0.

Would someone have a clue what is going on?

Website is : http://staging.tourismesutton.com/  (and no it is not Sutton England)

Share this post


Link to post
Share on other sites
Simon

It'll be a php setting or security .. Max post size something like that

 

look at server logs for the error

Share this post


Link to post
Share on other sites
claudedagenais

Hi,

OK I just moved this to a new account and I'm getting the same problem. I've looked at my other accounts with Platform 5 and they do the same. This also mean I cannot Activate the Pro version by the way - and I was able to do that before on the same server  with the same setup not long ago since I have other website that are registered (eg visitsutton.com is the lastest one and was launch less then 2 weeks ago). 

I've tried downgrading the PHP and deactivating the iTheme (and cleaning up .htaccess) to make sure it was not a security or this version of PHP. I did not change the setting of PHP (I've attache an image of the options I'm running).

In the server log I've got an error linked with the home directory. This is something that has to do with the previous account because it fits perfectly the other account URL. But trying to save my settings doesn't generate new error message:

[Tue Jun 21 07:55:14.086560 2016] [autoindex:error] [pid 114033:tid 139814980458240] [client 184.107.95.32:33787] AH01276: Cannot serve directory /home/tourismesutton/public_html/: No matching DirectoryIndex (index.htm,index.html,index.php,index.shtml,index.xhtml,index.pl,index.cgi,index.jsp,index.phtml,default.htm,default.html,home.htm,index.php5,Default.html,Default.htm,home.html) found, and server-generated directory index forbidden by Options directive

 

So I don't know... But I need that solved as soon as possible because we are going live with two websites that are affected in the same way by the end of the week.


 

 

php.jpg

Share this post


Link to post
Share on other sites
claudedagenais

Just to add the PHP options for this server:

php_options.jpg

Share this post


Link to post
Share on other sites
claudedagenais

I just want to add that for another site on the same VPS but different account, I was able today to Activate the Pro version but not to make any change to the Settings. But for this account I still cannot Activate the Pro version.

Share this post


Link to post
Share on other sites
Simon

open a ticket using button at the top, please provide admin login and FTP login, i'll have a look for you.

Share this post


Link to post
Share on other sites
Simon

Activation issue solved by simply disconnecting and reconnecting as per the FAQ

 

Share this post


Link to post
Share on other sites
claudedagenais

Thank you for this.

Now to the other problem - I'll do a screencast

Share this post


Link to post
Share on other sites
Simon

You had mod_security enabled in cpanel. I turned it off and all works normally.

As you have no access to the security logs we have no idea what was causing the issue im afraid.

 

Share this post


Link to post
Share on other sites
claudedagenais

You are THE man !

Thank you so much I now owe you a keg of beer !

Share this post


Link to post
Share on other sites

×