Jump to content
StuLeeUK

hentry error 'Missing: entry-title'

Recommended Posts

StuLeeUK

I have noticed in Google Search Console that I have a lot of errors in the structured data, all down to the error 'Missing: entry-title'.

All the other fields seem fine but this one error flags up on all blog posts.

Can anyone point me in the right direction please because I have no idea about this stuff and don't know where to start to try and fix it. Is it anything to even worry about?

Share this post


Link to post
Share on other sites
Simon

If you provide a URL to the site we might be able to help.

Share this post


Link to post
Share on other sites
StuLeeUK

That's a good point. It's avangocouriers.co.uk/blog/

Share this post


Link to post
Share on other sites
Simon
3 hours ago, StuLeeUK said:

 

That's a good point. It's avangocouriers.co.uk/blog/

 

This is an issue with the framework theme, i'll update it.

Share this post


Link to post
Share on other sites
StuLeeUK

Ok great, thanks for your help.

Share this post


Link to post
Share on other sites
StuLeeUK

Yeah I tried that tool and got the same result when i first started to realise I had a lot of errors, but despite it stating no errors I still get the list of problems in Google Search Console (as shown in the graphic attached).

I have no idea how much of an issue it's having on the site, just seems very odd to me and would probably be better if I got it sorted.

Google Search Console Errors.jpg

Share this post


Link to post
Share on other sites
Simon

Maybe a question on the google forums?

The google webmaster tool says there is a problem but the official google structured data validator says there isnt. So which is right? They are both google tools. 

Share this post


Link to post
Share on other sites
StuLeeUK

I Googled 'hentry missing title error' and it's come back with numerous results all pointing to issues with themes, including some from the Google webmaster forum, and I found this article on the 'yoast' knowledge base https://kb.yoast.com/kb/fixing-hcard-author-error/ . Although the page is initially about the 'author' error it refers to other errors part way down;

  • Missing: updated / entry-title / other
    The requested tag is not present in your theme or is incomplete. Please contact your theme developer for assistance.

I also noticed that on the Live Structured Data testing tool it states 'Data only shows detected fields' - so I'm assuming this means it's not showing an error as the titles are just not being detected?

So could you have been right in the first place that it's a slight issue with the theme?

Share this post


Link to post
Share on other sites
Andrew

Ya you are correct that this needs an update, the tool and necessary additional information is a new thing and we need to add this meta content to the elements. 

Share this post


Link to post
Share on other sites
Michael Kummer

Hi @Andrew! I just came across this issue as well for michaelkummer.com. It seems like the H1 tag in the Pagelines 5 framework is missing the entry-title tag. Have you guys ever done any updates/fixes in this area?

Thanks

Michael

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. 
      I have seen in the Google Websmaster Tool, that my website (https://www.wedding-photography-minneapolis.com/) has a problème with missing "entry-title" , missing "updated", missing"author". 
      A quick search on this forum reveal me that  I am not the only one! @Michael Kummer @StuLeeUK @travistsickle @Skip for exemple have the same issue.
      I have read that @Simon @Andrew premise (long time ago) it should be an update for this issue. But obviously there is still not. Or tell me if I am wrong ? 
      So I was wondering if some of you guys have found an alternative solution ? Like using a plugin? (if yes, witch one do you recommande).
      Or I was thinking maybe adding manually the  html code for each page ? (if yes , would you recommand a tutorial to do it) ?
      I have seen a couple a tutorial to add some php code in order to do that ( http://www.seomix.fr/microformats-microdata-wordpress/) .... BUT, I am really not a developper and I don't want to destroy the PL theme by adding so PHP in a bad way.
      I guess it's not a big issue, but if we can make google happy, that would be better !
       
    • yemoonyah
      By yemoonyah+
      Hi,
      I'm trying to hide my blog post titles on my single post pages but not on the blog page (where all posts are listed).
      Here is the code I use for that:
      .single-post .entry-header .page-title { font-size: 0; } But even though I specify that it should only happen on single post pages, it still shows on the general blog page.
      See here: http://yemoonyah.com/blog
      How can I fix that?
      Thanks,
      Yamile
       
    • Claude203
      By Claude203
      This is probably a simple problem to fix, but right now I am new to DMS concepts and therefore I'm stuck and can't seem to figure it out.
       
      On my pages, the page titles are no longer showing up at the top of the page, as they did before. No problem for posts, where the post titles populate just fine. But when I try to make a change to pages, the templates for the entire site change as well, also altering post layouts. So for example, on one particular page I want to make it a full width (no sidebar) layout, but when I make the change on that page, all other pages and all blog posts now suddenly have no sidebar as well. Every time I try to start over by creating a new page from scratch, any change I make there also changes every other page/post. I know this has something to do with templates and how they are linked to posts/pages, but I cannot figure out how to unlink them or what else it could be. 
       
      Thank you.
    • Mike.Wells.US
      By Mike.Wells.US
      Hey All
       
      I am having trouble trying to get my Page Titles above my Boxes on my website.  A good example is this page:
       
      http://www.avsuperfly.com/video-equipment-rentals-san-francisco/
       
      ....where for some reason it says RENTALS, at the very bottom after you've looked at all the Rentals.  Same deal in Sony Cameras, Canon Cameras etc.
       
      Is there a quick piece of code or some little box I can check to get Page titles appearing at the top of the page, above all the box content?
       
      Any help would be fantastic.  I'm on a slightly older version of page lines and currently too afraid to update.
       
      Regards,
       
      Michael
       
       
    • balfred1345
      By balfred1345
      Hi,
      I've got links in header tags in the footer in a columnizer section (therefore I'm using text widgets to supply the content) that aren't showing up in the proper color that I've set in Global options. The a:link is staying white, when it should be blue. The a:hover shows up correctly.
      I've tested this out in tags h4 through h6 and none get the proper CSS from Global options. 
       
      I tried adding the following in custom code, but it did not work:
      /* unvisited link for h6 */ #site h6 > a:link {   color:#006BED !important; }       I've tried using both <p> and <strong> tags and the a:link color does show correctly. The only problem is, that the text itself does not show up well enough against the background... which is why I want to use a header tag.    You can take a look at this in the footer under NEWS at:
      http://whub34.webhostinghub.com/~videoh6/cidev2.com/
       
      Any help would be greatly appreciated!
       
      Thanks,
      Bruce
×