Jump to content

Archived

This topic is now archived and is closed to further replies.

dtldesign

Pagelines 2.5 Update

Recommended Posts

dtldesign

I have a lot of old site running version 2.4.x of Pagelines.

I know there has been an update to 2.50 pushed through.

But now I can log-in to wp-admin page as all I get is 

Deprecated: Non-static method PageLinesTemplate::current_admin_post_type() should not be called statically, assuming $this from incompatible context in /home/modedevi/public_html/wp-content/themes/pagelines/admin/class.options.metapanel.php on line 30

Going into the server and hiding the theme files can get around this but I was wondering if this is going to be fixed?

 

Share this post


Link to post
Share on other sites
Simon

Later versions of that theme hid the warnings, 2.5.0 gets rid of them altogether, so you must have had quite an old version.

You have the following choices.

Share this post


Link to post
Share on other sites
dtldesign

It's been totally messing up widgets when updating so would it be easier to just hide the errors?

If so, how do I do that?

Share this post


Link to post
Share on other sites
Simon

It depends on how your PHP is setup on your host.

By default those 'warnings' should never be shown, display_errors should only be on on a development server.

If you want to continue to use an old version and never update again you could try one of the many solutions on the web: https://aristath.github.io/blog/wp-hide-php-errors

Share this post


Link to post
Share on other sites
dtldesign

Thanks. I'll update and sort it out.
Thanks for your help.

 

Share this post


Link to post
Share on other sites

×