Jump to content

Archived

This topic is now archived and is closed to further replies.

FRevi

NextGEN Gallery fix w/latest versions?

Recommended Posts

FRevi

I have read several posts regarding conflict with NextGEN Gallery plugin. I am having a different problem - the galleries just fail to show up. I am running the latest versions of P5 and NextGEN, do you know if the fix plugin will solve that? Should I just try it and see what happens? thx


Ⅎʀ

Share this post


Link to post
Share on other sites
Simon

Fix plugin?

Share this post


Link to post
Share on other sites
FRevi

On Aug. 20 you said to someone else to try the plugin you "posted a while back"  fix-dms2-jquery.zip. Now that I look at it, this is not for Platform 5 anyhow.

So my question is: Is there anything I can do (besides contact NextGEN support which I have done but not heard back) to revive my NextGEN galleries on my Platform5 site? Do you possibly  have a fix or suggestion?

thx

 

 

 


Ⅎʀ

Share this post


Link to post
Share on other sites
Simon

You'll have to go into more detail, I just reinstalled nextgen and as far as I can see it still works.

 

Share this post


Link to post
Share on other sites
FRevi

Thank you. I also just deleted and reinstalled it - NextGEN Gallery and NextGEN Plus - same problem; i.e., the area of the page is blank where the gallery should be. It seems to be the NextGEN Plus plugin. When I turn that off and use just the basic Gellery functionality, it works. But the basic functionality is useless, so it would be great to have a solution. I'm trying to work with their support people as well. Any chance your developers could be in touch directly with theirs?  thx


Ⅎʀ

Share this post


Link to post
Share on other sites
Simon
22 minutes ago, FRevi said:

Thank you. I also just deleted and reinstalled it - NextGEN Gallery and NextGEN Plus - same problem; i.e., the area of the page is blank where the gallery should be. It seems to be the NextGEN Plus plugin. When I turn that off and use just the basic Gellery functionality, it works. But the basic functionality is useless, so it would be great to have a solution. I'm trying to work with their support people as well. Any chance your developers could be in touch directly with theirs?  thx

Sure, ask them to contact us. I have no idea what their 'pro' product does however.

Share this post


Link to post
Share on other sites
FRevi

The Pro (and Plus) versions just add more gallery types basically, surely they are more complex.

However, even in the basic version of NextGEN Gallery, only the Basic Thumbnails and Basic Slideshow work. The Basic Image Browser does not work. Maybe that might help you pinpoint a problem? I've told them about it too. Why can't we plugins all just get along?


Ⅎʀ

Share this post


Link to post
Share on other sites
FRevi

Also, how should they contact you? Is there an email address that they can send a message to that will get through and get them hooked up with your people? You could send an email to [email protected] telling them who you are and how to contact you dev-to-dev. It would be great if you could get together and work out the kinks. Thanks.


Ⅎʀ

Share this post


Link to post
Share on other sites
Simon

Contact link, top of this page ;)

Share this post


Link to post
Share on other sites
FRevi

What Becky over at Imagely (Gallery plugin) suggests is this. Does it make sense? I'm not a coder so I have no idea what it means, and I hesitate to edit php files. Is it worth a try?  Thanks.  -Frank

...check for conflicting code in the Theme functions, JQuery or Javascript. You might also confirm that the footer is called in the footer.php and the header is called properly:
 
1. Add <?php wp_head(); ?> to your "header.php" right before </head>
 
2. Add <?php wp_footer(); ?> to your "footer.php" right before </body>
 
If the above doesn't work, go to the plugins nggallery.php file to define('NGG_DISABLE_RESOURCE_MANAGER') above the line that loads the resource manager PHP file. If you add the same to your wp-config.php it'll keep the same effect through the future in case when you upgrade NextGEN.
 
Those two constants (NGG_DISABLE_FILTER_THE_CONTENT & NGG_DISABLE_RESOURCE_MANAGER) *should* fix most theme / plugin compatibility issues.
 
If the theme or styling / JS is all weird try disabling the resource manager; if galleries aren't appearing at all or the rest of the page/post content is missing except the gallery, disable "the_content" one.

Hi Simon.

Disregard the above comment, it's obsolete now.

I gave Cais over at Imagely permission to tell you the credentials to my web site that I made for her. I really appreciate your following up on this, it's so great. Thanks.


Ⅎʀ

Share this post


Link to post
Share on other sites
Simon

@FRevi cais should have emailed you.

Share this post


Link to post
Share on other sites
FRevi

Yes, thanks, I have one email from Cais just a short while ago saying you two are sorting out the issue. She'll share the credentials for my site with you so you can both get in. If there's a more recent email, I don't have it yet, but I'll keep an eye out. Thanks  -Frank


Ⅎʀ

Share this post


Link to post
Share on other sites
Simon

Frank, Cais' name is Edward ;)

He asked you to forward me the credentials to [email protected]

Share this post


Link to post
Share on other sites
FRevi

Hi Simon.

I think I forwarded you the credentials to my site with the Gallery issues. Have you had a chance to address the problem? Edward seems to think it's a problem on your end.  thx


Ⅎʀ

Share this post


Link to post
Share on other sites
FRevi

Hi Simon.

Do you have a response to this issue with NextGen Gallery plugin compatibility?

I believe you have been in contact with Edward Cais over at NextGen, who it seems has found a problem on your end. My site is still down after weeks and I sure would like to get it back up again soon. It relies on both Framework 5 and NetGen Gallery, and I don't want to have to chose one and rebuild the site. Thanks for your prompt reply.


Ⅎʀ

Share this post


Link to post
Share on other sites
Simon

It isnt a problem our end, and Ed is waiting for their devs to figure out why their plugin is failing to load its own javascript file.

Share this post


Link to post
Share on other sites
FRevi

According to Ed today:

Although I can appreciate Simon kicking this back to us, we are only seeing the issue with their code active ... although our code is not being loaded we cannot find a reason for why this is the case when you are using their code. Granted that is of no help at all for you, but we simply have no idea why this is the case when using their theme/plugin. I have advised our developers of this issue but we do not have it on our current schedule to resolve as we do not know where to start except that it will have something to do with the PageLines code in your case.

So I'm left with two plugins that I've paid for, a site that's been broken not for hours but for weeks, each company blaming the other, and no solution. This is not acceptable.They have supposedly 5 million sales; I think it would be good for you to be compatible with that, no? I've told them they should be compatible with your best in class framework, too.

You have a great product and great support. I'm asking you to do the right thing and get together with Imagely to solve your mutual incompatibility.

 
 

Ⅎʀ

Share this post


Link to post
Share on other sites
Susan

I wanted to purchase NexGen Plus but am concerned that it will not work with PL5. Is this the case? 

Share this post


Link to post
Share on other sites
FRevi

As of now they are incompatible. I have emailed extensively with Nexthen and posted here at pagelines. Both acknowledge the incompatibility and confirm that they have no intention of addressing it. I had to go with a different gallery.


Ⅎʀ

Share this post


Link to post
Share on other sites
Susan

FRevi, I appreciate your reply. May I ask what galleries  you found that are compatible?

Thanks so much.

 

Share this post


Link to post
Share on other sites
FRevi

I'm using Envira gallery now. It doesn't have all the features and adjustability, but it seems to work in P5. Cheers

-Frank


Ⅎʀ

Share this post


Link to post
Share on other sites
Susan

Ok - thanks Frank.

 

Share this post


Link to post
Share on other sites
Simon

Unfortunately the nextgen code is completely unreadable. They use strange libraries and code practices that frankly nobody else ever uses.

Our plugin does nothing out of the ordinary.

We recently added a compatibility mode  under the wp-admin advanced options, try it as it might make a difference.

Share this post


Link to post
Share on other sites

  • Similar Content

    • kratma
      By kratma
      When I updated to Framework 2.4.5 images from NextGen Gallery no longer displayed in the carousel. I got this message  The plugin for the selected carousel mode needs to be activated (FlickrRSS or NextGen Gallery)
       
      I deactivated and reacdtivated the plugin. I tried removing it completely and re-installing but get the same message.
       
      I took the carousel out and set it up on a trial page
       
      Website  http://goodheartbooks.com
      Sample page with carousel us  http://goodheartbooks.com/trial/
       
      Wordpress version 3.9.1
       
      Thanks
       
    • jbrouwer
      By jbrouwer
      Hi,
       
      Just installed the Nextgen Gallery 2.0 plugin. The admin pages of the plugin were white. Turned out it was related to Pagelines Framework (disabled all plugins and tested on twenty twelve). I started with looking which js files were loaded on the Nextgen Gallery admin pages and it was navbar.js. After disabling the fixed navbar in the site options menu the NextGen Gallery admin area was fine. Since there is no use for the navbar.js file to be loaded in the admin area, can this be changed so it only loads on frontend?
       
      Thanks.
    • Bleuy
      By Bleuy+
      Evening All
       
      I am looking to create a carousel affect on my website, which consists of 13 scrolling images, I only want to show 4 at a time, with left and right navigation.  These images relate to Pages (not posts) and I therefore need to have a link from the image to the relevant page.  I have looked through the forums seen a variety of old options (+ none of them seem to specifically relate to my request), but wondered if someone could give me best advise please?
       
      I have installed the NextGen plugin (but for some reason the images are not loading & not sure the Flickr one is relevant) + I can't see a way of linking this to the relevant pages.
       
      Your assistance/advice, as always, greatly appreciated.
       
       
×