Jump to content

Archived

This topic is now archived and is closed to further replies.

navigador

MegaNav - how do you repeat on all pages?

Recommended Posts

navigador

I only just got to start my first PL5 site today, and loving it already.

 

However, I swapped out basic nav menu with the MegaNav, but it only appears on the home page. Any ideas on how to get the same menu sitewide?

 

Cheers

Share this post


Link to post
Share on other sites
Aires

Make sure you have the meganav in the header part and not the template area


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
navigador

@Aires , many thanks - so easy when you know where to look. Just a little drag and drop into the header did the trick - Cheers.

Share this post


Link to post
Share on other sites
schusterchiro

Just converted too... I tried to drag and drop but there is a grayed out box below the header title saying "using a theme header" and I am unable to drag the MegaNav to the deader area. Any suggestions?

Thanks,

Marcus

Share this post


Link to post
Share on other sites
Aires

That because you are using it with another theme.


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
schusterchiro

I just realized that was a silly question... I figured it out. I'm still a little new at this.

Marcus

Share this post


Link to post
Share on other sites
Andrew

ya with non PageLines optimized themes, we have to default to using the theme header as we can't make assumptions. In the future we'll be adding ways for you to fix this with a hook.

Share this post


Link to post
Share on other sites
Aires
5 hours ago, Andrew said:

ya with non PageLines optimized themes, we have to default to using the theme header as we can't make assumptions. In the future we'll be adding ways for you to fix this with a hook.

Awesome !!!


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites
travistsickle

I'm using the DMS2 theme and it says using a theme header. Is there a way to edit that?

Share this post


Link to post
Share on other sites
Aires

There is away but it would require you to add a header php file to your child theme and adding some code to make the header area of another theme open to sections. 

I don't think they recommended it but it could be done.


ndTgvai.jpg

Visit iheartpagelines.com for the latest tutorials on PageLines related products.

 

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • mtaus
      By mtaus+
      I'm using MegaNav on this site and the menu items and logo are "sticky" (which I selected), but the background scrolls. 

    • abeedle
      By abeedle+
      It appears that within the default settings for MegaNav menu items are slightly opaque when they are not selected or hovered over. Then on the selected page and on hover of the menu item opacity goes to 1. It's not a big deal in most cases but we are including a button on a client's menu and the white text just doesn't stand out as well unless you are on the page itself and the opacity has changed to 1.
      My question is whether there is a way to essentially flip the default settings so that when a menu item is not selected/hovered over the opacity is 1 and when the page is selected/on hover the opacity is slightly less than 1.
      I assume the fix would be by using custom CSS and we have tried a few different methods of attempting to target the menu opacity without success.
      Any help would be greatly appreciated! Thanks!
    • oseehys
      By oseehys+
      Hi @raylonet @Aires Dagraca A. Hey Guys, if i can fix this i wont be here, please help out here.
      I am trying to align some of my menu Items to the right, as it is on Pagelines website, Pagelines is using Navpro, i am aware.
      But i am using Meganav and UberMenu, because it naturally synchronize with Ubermenu, NavPro doesnt.
      How can i align my menus to the right and leave the primary menu at center, see images

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

×