Jump to content

Archived

This topic is now archived and is closed to further replies.

johnschreiber

Tablepress DB Initialization Issue

Recommended Posts

johnschreiber

All,

Hoping you can help me with an issue I'm having with TablePress v1.7  and PL5 5.0,89.

I've created a page and added the shortcode for the table I created in the TablePress plugin. My issue is that each time I load or refresh the page I get the following error:

DataTables warning: table id=tablepress-1 - Cannot reinitialise DataTable. For more information about this error, please see http://datatables.net/tn/3

I've done some looking on this and found a thread here, but I cannot find the issue being referred to.

I am new to a lot of this, and would appreciate any help you can provide in resolving this issue. I am running the site currently under WAMP on my laptop.

Thanks for all your help,

John

 

Share this post


Link to post
Share on other sites
johnschreiber

Simon,

Thank you for responding. When I try to load this page I get the following error:

Sorry, there is a problem

You do not have permission to view this page

Error code: 2T187/3

 

Can you help?

Share this post


Link to post
Share on other sites
Simon

Ok well the fist of it was .. In table press settings to turn off Ajax 

Share this post


Link to post
Share on other sites
johnschreiber

Simon,

When I turn these setting off. I loose the functionality I wanted from the plugin in the first place.

Any ideas and, to the larger audience, are there any alternatives that others like to use?

Thanks!

Share this post


Link to post
Share on other sites
oksodavid

@simon I just checked this on clean instal, and get the same 'cannot reinitialize' error.

yep, if you don't load the js you fix the error, and loose the sorting functionality you require from datatables

Share this post


Link to post
Share on other sites
Simon

Pl5 uses knockout .. Table press Ajax had an issue with knockout and they are in no hurry to fix the issue .. 

Share this post


Link to post
Share on other sites
oksodavid

@Simon thanks for info. I took  a look and found tablepress jquery script is loaded twice only when pl5 core plug is enabled - the script appears twice in page source.

I loaded 2015 to test and found it occurs only when having pl5 enabled, not an issue with pl theme/footer etc. From TablePress author...

This indicates that this other plugin is somehow modifying how JS is loaded into the page.
I'm afraid that there's nothing that I can do about this in TablePress.

He didn't see any issue with Knockout.js/content template and binding in pl.

Any ideas your side?

Share this post


Link to post
Share on other sites
Simon

Think ive fixed this in next release..

Share this post


Link to post
Share on other sites
Simon

@oksodavid if you are on slack, ping me and you can help test the fix...

Share this post


Link to post
Share on other sites
oksodavid

wicked! I'm testing with acf repeater fields into tablepress, to get mobile layout, custom filter and sort functionality. would be great to have this work.

Share this post


Link to post
Share on other sites

×